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Chapter

   1    What's New

What's New
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What's New in Tecnomatix Plant Simulation 14

What's New in Tecnomatix Plant Simulation 14

Tecnomatix Plant Simulation 14 provides a number of new and improved features.
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• Important Changes in Plant Simulation 14

• Simulation- and Animation-Relevant Changes

• New Features of the Material Flow Objects

• Changed Features of the Material Flow Objects

• New and Changed Features of the Fluid Objects

• New and Changed Features of the Resource Objects

• New Features of the Information Flow Objects

• Changed Features of the Information Flow Objects

• New and Changed Features of the User Interface Objects

• New and Changed SimTalk Features

• Miscellany

• New 3D Viewer Features

• Changed 3D Viewer Features

Back to What’s New

Important Changes in Plant Simulation 14

Tecnomatix Plant Simulation 14 provides a number of new and improved features.

Security

We added the setting File > Model Settings > General > Access to the computer is
prohibited to ensure that simulation models, which you receive from others, do not damage your
computer.

• To facilitate this via SimTalk, we added the method isComputerAccessPermitted.

• To facilitate this via SimTalk, we added the method SetTrustModels to the COM interface.

• If you activate this security setting, this also affects a number of methods that can access
your computer.

• We added the start option -TrustModels. When you enter this start option, Plant
Simulation treats models, which you receive from others as if they were your own models.
When you open a model that your received from somebody else, for which the model
setting permits access to the computer, Plant Simulation does not notify you about this.

Models, which were saved with a version older than 14, do not receive a trust ID and thus
are always considered to be models from other people. Normally access to the computer
is denied when loading an old model into version 14. If you entered the start option -
TrustModels, the old model automatically has access to the computer.
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• We added the setting Access to the computer is permitted to libraries.

We added another parameter to the method getLibraryInfo allowing you to query access to
the computer.

Save Models via Active Workspace to Teamcenter

You can now use Active Workspace to add your Plant Simulation models to the Teamcenter
database and to later open them from the database.

With Active Workspace you can:

• Select the target folder of the model with the command File > Teamcenter > Add to
Teamcenter.

• Select a model with the command File > Teamcenter > Open from Teamcenter.

Active Workspace in the Teamcenter Interface

We added Active Workspace to the Teamcenter Interface. You can use it to select Teamcenter
objects via Active Workspace and to further process these objects in Plant Simulation.

You can:

• Select an application interface object in the dialog of the Teamcenter Interface via
Active Workspace.

• Select the target folder of the Report in the dialog of the Teamcenter Interface via
Active Workspace.

Animation area

We added settings for the animation area to the tab MU Animation of the objects with matrix
loading space. The animation area replaces the function Create Paths > Create Locations
of previous versions of Plant Simulation.
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Scale automatically

We replaced the setting Auto graphics active for the MUs with the setting Scale
automatically. It adjusts the size and the position of the graphic of the MUs to the dimension and
the booking point of the MU in 2D.
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Simulation- and Animation-Relevant Changes

We made changes that are relevant for the simulation and the animation in Tecnomatix Plant
Simulation 14. For this reason you have to adapt simulation models which you created in
previous versions of Tecnomatix Plant Simulation, when you open them in Tecnomatix Plant
Simulation 14.

Simulation- and Animation-Relevant Changes in Plant Simulation 14.0

• We changed the behavior of the feature setup after n parts with the setting After last
part. If you entered a formula for the setup time, the anonymous identifier @ was void in
previous versions when the machine was set up after the n-th part. Now you can access the
n-th part with @.

• We changed the behavior of the Store when it delivers mounting parts for an
AssemblyStation and when several parts in the Store are simultaneously unblocked for a
main part. From this version on the parts arrive in reversed order at the AssemblyStation.

• We changed the behavior of the read-only attribute CurrentSpeed of MUs on Lines.
CurrentSpeed now always has the sign (+ or -) of the respective direction of movement of
the Line. In previous versions the sign of the CurrentSpeed could differ from the direction
of movement of the Line when the MU was conveyed by a Converter beforehand.

• We changed the behavior of method initialize of the TableFile. If you tried to initialize
the column index, for example with TableFile.initialize({0,*}, "AA")), Plant
Simulation did not execute this and retained the previous values. Now Plant Simulation
assigns the passed initial value.
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• We changed the behavior of the attribute Coordinate3D: It now returns an array of data
type length instead of data type real as in previous versions.

Simulation- and Animation-Relevant Changes in Plant Simulation 13.2

• We changed the behavior of the SQLite Interface: When you open a file-based SQLite
database, Plant Simulation applies the following default settings, which deactivate
transaction support:

PRAGMA locking_mode=EXCLUSIVE

PRAGMA journal_mode=NORMAL

PRAGMA synchronous=OFF

These settings considerably accelerate access to the database.

To get the SQLite default settings, which support transactions, you can use the following
instructions:

SQLite.exec("PRAGMA locking_mode=NORMAL");
SQLite.exec("PRAGMA journal_mode=DELETE");
SQLite.exec("PRAGMA synchronous=FULL");

• We fixed non-expected behavior that occurred in the method find of lists and tables. When
you searched a table and then started a second search, for which you entered a range, which
did not contain the cell of the first search, the search was only started after the first cell of
the new range, as the search was continued.

Now we reset the search and the search then starts in the first cell of the range as if a call of
the method setCursor had been executed.

Simulation- and Animation-Relevant Changes in Plant Simulation 13.1

• When resetting the simulation model, Plant Simulation now does not call the Request
control, the Receive control, and the Release control of the Importer any more.

This is because the MUs are deleted when resetting the simulation model. This then
triggered the release control for example. Normally you can access the active MU with
the anonymous identifier @. As the active MU was deleted while resetting the model,
the Debugger opened. For this reason you had to program source code in your model that
handled a case that never occurred during the simulation.

• The new settings of the 3D-Viewer-function MU side to attach caused the state of
the setting to convert the animation path to the new setting. A model, that relies on a
certain inheritance state of the MU Animation and then changes the state with SimTalk
commands, might lead to a changed animation for the object Pick-and-Place-Robot.

Back to What’s New in Tecnomatix Plant Simulation 14

New Features of the Material Flow Objects

Tecnomatix Plant Simulation 14 provides a number of new features.

New Features in Plant Simulation 14.0

• We added the setting MU conveying direction to the tab Attributes of the Pick-And-
Place-Robot.
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• We added the Tab Importer to the Pick-And-Place-Robot. This way you can order a
Worker for repairing the services to remove the failure.

• We added the setting Off to the dropdown list Set-up depends on. It deactivates setting the
object up after changing the type to another MU. This means that the station will only be
set-up after the number of parts that you selected.

• We added the Z-dimension to the Store, the Container, and to the Transporter. This allows
you to stack parts on these objects.

• We added the attribute MUHeightWithContent to the MUs. You can use it when stacking
parts.

• We added the setting Throughput per Minute to the tab Tab Type-dependent Statistics
of the Drain.

• We added a setting to the object Interface to show the number of the next aimed at exit on
the tab Exit when you already determined that exit.

New Features in Plant Simulation 13.2

• We added the setting Only for empty blocking list to the tab Attributes of the Pick-And-
Place-Robot.

• We added the setting Target selection to the tab Exit of the Pick-And-Place-Robot.

• We added the Loading time and the Unloading time to the tab Attributes of the Pick-And-
Place-Robot.

• We added the method findFreePlace to the Store.

• We added the read-only attribute LocationInFrame to the MUs.

• We added the attribute TargetDistance to the Transporter.

• We added the command Delete Sensor to the context menu of length-oriented objects in the
Frame. To delete a sensor in 3D, press the Del key on the keyboard.

• We added the method getHTMLCode for all objects which can create a statistics table in
the HtmlReport.

• The button  in the text box of the control on the tab Controls now provides these
commands:
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New Features in Plant Simulation 13.1

• We enhanced the functionality of the Source. For the setting Time of creation > Interval
Adjustable you can now also set the Amount of parts to be produced. When you do not set
the Stop time, Plant Simulation produces the amount of parts you entered at most.

• We added the setting Assembly table > Depends on Main MU to the Assembly station.

• We added the menu command Calculate Dimensions from 3D to the Tools menu of the
MUs.

• We added the method getStoragePlace to the MUs. You can use it to find out on which
storage place within a Store the MU is located.

• We increased the number of Parameters which observer methods accept. You can declare
observer methods with one, two, or three parameters.

• We added the optional parameters Destination and Name to the methods derive and
duplicate to enable these methods to replace the method createObject. To create the
object at a certain position in the Frame as with the method createObject, use the attribute
Coordinate3D.

• We replaced the method setUp with the method resSetUp.

Back to What’s New in Tecnomatix Plant Simulation 14

Changed Features of the Material Flow Objects

Tecnomatix Plant Simulation 14 provides a number of changed and improved features.

Changed Features in Plant Simulation 14.0

• We changed how the function Fast Forward Simulation of the Eventcontroller works. It
now automatically deactivates Realtime mode. When you terminate Fast Forward
Simulation, Realtime mode will be activated again, provided it was activated before.

You can now quick and easy switch between Fast Forward Simulation and normal
simulation by clicking the respective button while the simulation is running.

• We changed the behavior when querying the contents list of a length-oriented object or
of the position list of an MU on a length-oriented object with the methods contentsList
and positionList. The values for the positions are not rounded any more.

Changed Features in Plant Simulation 13.2

• We extended the functionality of the method outIn. You can now also specify outIn(-1,
true) for fully processed parts.
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• We changed the behavior when an object, on which a blocked MU is located, is failed/
paused/stopped: Now the MU is no longer removed from the blocking list when the MU
you unsuccessfully attempted to move it with one of the methods insert, move, or transfer
before an Out event was processed for this MU.

• We changed product statistics of the MUs: MUs, which are located in a blocking list,
are now always counted as waiting, no matter which state the material flow resource is in.
MUs, which are loaded or unloaded from a resource by a Pick-and-Place Robot, are always
counted as working.

Changed Features in Plant Simulation 13.1

• We now enter root.Broker into the text box Broker by default into the sub-tabs of the
Tab Importer. For this reason Plant Simulation now does not show an error message any
more when you click on Apply. When Plant Simulation detects an invalid Broker during
the simulation, it opens the dialog of the object with the respective sub-tab.

• We changed the behavior of Plant Simulation. Now no events are calculated any more
when resetting your model. This now happens when initializing the model.

You can now also initialize attributes, which affect event generation, for example the
availability, in the Init Control. For this the init controls are now executed before
the events are calculated. The normal init methods, on the other hand, are executed after
calculating the initial events.

Based on this enhancement the Init Control of the Transporter will now also be executed
before the events are calculated. In previous version the init control was executed after
the events were calculated.

• We changed the behavior of the Exit strategy > Carry part away. It is not allowed any
more for objects which are part of a balanced line. For models, which you created in
previous versions, Plant Simulation deactivates the object Cycle when you had activated
Carry part away for one of the objects it controls.

• We changed the behavior of the Assembly station. When it has objects of type Store as
predecessors, it requests the required mounting parts from the Store. If the required parts
are not available in the Store at the moment, the Store records the request and delivers the
parts to the Assembly station when they are available again.

The parts can also be carried from the Store to the Assembly station by a Worker. The
Store can only provide mounting parts, but no main parts and has to be connected with a
Connector, even when the Worker carries the part away.

• We changed the behavior of the method mu of the Container, the Transporter with a
loading space, and of the Store. You can now call it with the parameter -1. Then the
method returns the last MU on the object or VOID when the object is empty. You can, for
example, use the method to unload a Container in reverse order.

• We changed the behavior of Plant Simulation. The method finishedTime of the MUs is
now observable.

• We changed the behavior Plant Simulation. The attribute RemainingSetupTime is now
observable.
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• We do not support the method createObject any more. Use the methods derive or
duplicate instead. To create the object at a certain position in the Frame, use the attribute
Coordinate3D.

• We do not support the method ShowStandardMenus any more.

Back to What’s New in Tecnomatix Plant Simulation 14

New and Changed Features of the Fluid Objects

Tecnomatix Plant Simulation 14 provides a number of new and improved features.

New Features in Plant Simulation 13.2

We added the observable attribute currentMaterial to the Portioner.

New and Changed Features in Plant Simulation 13.1

• We added the Tab Controls and the Ingredient complete control to the Mixer.

• We replaced the method setUp with the method resSetUp.

Back to What’s New in Tecnomatix Plant Simulation 14

New and Changed Features of the Resource Objects

Tecnomatix Plant Simulation 14 provides a number of new and improved features.

New and Changed Features in Plant Simulation 13.1

We changed the behavior of the Workplace when you create a new model. Now Worker stays
here after completing the job is activated by default.

Back to What’s New in Tecnomatix Plant Simulation 14

New Features of the Information Flow Objects

Tecnomatix Plant Simulation 14 provides a number of new features.

New Features in Plant Simulation 14.0

• We added the method deleteContent to the TableFile.

• We added a message when you try to change the source code of a read-only Method.

• We added an optional parameter to the method open of the FileInterface.

• We added an optional parameter to the method open of the SQLite Interface.

New Features in Plant Simulation 13.2

• We added the PLCSIM Interface.
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• We added the feature Statements to the SQLite Interface.

• We added the method executeStatement to the SQLite Interface.

• We added a feature allowing you to set a class breakpoint and/or an instance breakpoint
for an encrypted method. The Method then stops at, respectively during, method execution
in the Debugger.

When you did set a breakpoint, this Method shows the breakpoint with the respective icon
within the Method editor or the Method debugger before the message Source code is
encrypted.

New Features in Plant Simulation 13.1

• We added the OPCUA Interface.

• We added the PLCSIM Interface.

• We added a function which shows the elapsed time in the status bar of the Method
Debugger when you execute one or several instructions in a Method with the commands
Step Over (F10), Step Into (F11), Step Out (Shift+F11) or Run to Cursor (Shift+F10)
and when executing the instructions takes 10 milliseconds or longer.

• We added the tab Anonymous Identifiers to the watch window of the Method. Plant
Simulation now shows the anonymous identifiers @ and ? on this tab instead of the Tab
Variables as in previous versions of the program.

• We now mark temporary breakpoints and bookmarks in the source code of a Method in a
brighter color than saved breakpoints and bookmarks. This might, for example, be the case
when you changed the source code of a Method and set a breakpoint or a bookmark after
the original end of the source code. These breakpoints or bookmarks are lost when you do
not apply the source code.

• We added the method getHTMLCode to lists and tables.

• We added the method copyContentTo to the lists and tables.

Back to What’s New in Tecnomatix Plant Simulation 14

Changed Features of the Information Flow Objects

Tecnomatix Plant Simulation 14 provides a number of changed features.

Changed Features in Plant Simulation 14.0

• We changed the behavior of the column width of lists and tables. It is now limited to 180.

• We removed support for the method selectSyncFromDialog of the Teamcenter Interface.

Changed Features in Plant Simulation 13.2

• We fixed non-expected behavior that occurred in the method find of lists and tables. When
you searched a table and then started a second search, for which you entered a range, which
did not contain the cell of the first search, the search was only started after the first cell of
the new range, as the search was continued.
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Now we reset the search and the search then starts in the first cell of the range as if a call of
the method setCursor had been executed.

• We added the columns Description and Creation Date to the tables in the dialog
Select Teamcenter Sync (Import). In addition, you can now sort the columns in the
tables.

• We changed the names of the following interface objects:

Old Name New Name
OPCUAInterface OPCUA
OPCClassicInterface OPCClassic
SIMITInterface SIMIT

Changed Features in Plant Simulation 13.1

• We renamed the OPCInterface to OPCClassicInterface and we added the
OPCUAInterface.

• We activated the setting Decimal places for the Variable for variables of data type time.

• We replaced the methods indexXDim and indexYDim of the TableFile with the read-only
attributes XDimIndex and YDimIndex.

• We changed how Plant Simulation exports data from tables with the command Export
Excel File to the Excel format: Until now Plant Simulation always used the proprietary SI
units and not the unit that you had selected. Now Plant Simulation exports the data with
the settings that you selected for the units. Suppose that you selected Foot as the length
unit for a column of data type Length. Then Plant Simulation exports the values in Feet to
Excel and interprets the values as Feet when you import them back to Plant Simulation.

• We added an optional parameter to the method openDialogBox. You can use it to set that
the column widths will be calculated automatically.

• We do not support the attributes ShowToolbar and ShowStandardMenus any more.

Back to What’s New in Tecnomatix Plant Simulation 14

New and Changed Features of the User Interface Objects

Tecnomatix Plant Simulation 14 provides a number of new and improved features.

New and Changed Features in Plant Simulation 14.0

• We added the object WorkerSankeyDiagram to the User Interface objects.

• We added a message that asks if you want to cancel your changes when you click Cancel
or press the Esc key in the dialog of the object HtmlReport.

New and Changed Features in Plant Simulation 13.2

• We added access to cells of lists and tables in the object HtmlReport.

• We changed the syntax of the method getHtmlCode of the Chart.
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New and Changed Features in Plant Simulation 13.1

• We added the method setEditType to the object Dialog.

• We enhanced the functionality of the object HtmlReport. You can set the table columns for
objects which show statistics tables in the report, compare Display Statistics Values of an
Object as a Table in the Report.

• We changed the unit with which Plant Simulation shows the width and the height of the
objects DropDownList and Button. In previous versions these were displayed in pixels,
now they are shown in meters.

To facilitate this, we introduced the attributes ObjectWidth and ObjectHeight and we
removed support for the attributes Width and Height.

• We moved the setting Data in the dialog of the object Chart from the tab Display to the
Tab Data.

The setting Display in Frame on the tab Display now also affects 3D.

When Display in Frame is activated, you can now enter the Width and the Height of
the chart in length units, for example in meters. You can also set the dimensions with the
attribute SizeInFrame.

• We replaced the methods getValue and setValue of the object Display with the attribute
Value.

Back to What’s New in Tecnomatix Plant Simulation 14

New and Changed SimTalk Features

Tecnomatix Plant Simulation 14 provides a number of new and improved features.

New and Changed Features in Plant Simulation 14.0

• We added the keyword waitExpired. This way you can specify a time limit for waituntil-
and stopuntil-statements.

• We made these changes in connection with the internal web server of Plant Simulation:

o The internal web server will now only be started when you entered the start option -
WebServer or -WebServer:Portnumber.

o The function portNumber now returns 0 when the web server has not been started.

o For the function openHTMLBrowser URLs that begin with L/ only work when the
web server has been started.

New and Changed Features in Plant Simulation 13.2

• We added the method appendArray to the arrays.

• We changed the behavior of the wait instruction: When it is executed with a negative time,
Plant Simulation opens the Method Debugger and shows an error message. In previous
versions a negative wait time was implicitly changed to 0.

• We added the method _3D.activateMaterialWithColor for the MUs.
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New and Changed Features in Plant Simulation 13.1

• We enhanced the functionality of the modulo operator, compare Arithmetic Operators.
They now also work for floating point values.

• We enhanced the functionality of the arrays. You can now add and subtract arrays of
numerical data types.

• We added the function getErrorStop.

• We enhanced the fuctionality of SimTalk 2.0. You can now enter time literals:

wait 1:30  -- wait 1 Minute and 30 seconds
&Method.methCall(1:0:0:0.5) -- call the Method in 1 and half a second

• We changed the behavior of Plant Simulation. When the SimTalk functions for arrays min
and max are called with two values, which have the same physical unit, the return value
now also has this value. Compare these examples

min(time, time)        -> time
min(length, length)    -> length
min(length, speed)     -> real
min(length, real)      -> real
min(integer, integer)  -> integer
min(integer, real)     -> integer
min(real, integer)     -> integer
min(integer, weight)   -> real

• We changed which objects the method numOfLimitedObjects does not count as well,
namely objects of type Interface and EventController.

Back to What’s New in Tecnomatix Plant Simulation 14

Miscellany

Tecnomatix Plant Simulation 14 provides a number of new and improved features.

New and Changed Features in Plant Simulation 14.0

• We moved the settings for Connectors, namely Connect objects automatically and
Connector positioning from the tab User Interface to the tab General in the dialog
Preferences.

• We added the settings for Connectors to the tab General in the dialog Model Settings.

• We matched the categorization of the attributes and methods in the Online Help in the
Online Help with the categories in the dialog Show Attributes and Methods in Plant
Simulation itself. We now list the Methods of the Material Flow Objects, the Read-Only
Attributes of the Material Flow Objects, and the Attributes of the Material Flow Objects.

New and Changed Features in Plant Simulation 13.2

• We matched the description of the syntax of Methods and Attributes in the Online Help
with the signature in the dialog Show Attributes and Methods in Plant Simulation.

• We matched the categorization of the attributes and methods in the Online Help in the
Online Help with the categories in the dialog Show Attributes and Methods in Plant
Simulation itself. We now list the Methods of the Material Flow Objects, the Read-Only
Attributes of the Material Flow Objects, and the Attributes of the Material Flow Objects.
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• We changed the selection that Plant Simulation offers when creating a new simulation
model. Plant Simulation now only asks if you want to create 2D model or a 3D model. The
setting 2D and 3D is not required any more as you can activate 3D any time for an existing
2D model by clicking Activate 3D on the tab Windows of the ribbon bar.

Previous Versions From Version 13.2 on

• We changed how Plant Simulation shows a user-defined ribbon tab. In previous versions
Plant Simulation showed it under the ribbon tab/category Frame or 3D. Now Plant
Simulation shows it as a ribbon tab/category of its own named User.

Previous Versions From Version 13.2 on

• We renamed the tab Modeling to 2D. This allows us to hide the tab 2D when you are only
working with a 3D model.
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• We moved the Connector settings Connect objects automatically and Connector
positioning from the tab 2D to the tab User Interface in the Preferences dialog.

• We changed the behavior of the View Options, such as Show Object Names, in the
Frame. When you change one of these settings Plant Simulation changes it in the class
from which this setting is inherited. If you only want to change the setting in the local
instance, you have to deactivate inheritance first. We changed this because, as a rule,
you will want to change the setting for all instances of the Frame.

• We added the check box Requires 3D to the dialog Edit Library Information. When you
load a library for which this setting is selected, and when the 3D Viewer is not activated,
you will be asked if you would like to activate the 3D Viewer. When you click No, the
library will not be loaded.

• We moved the command Edit 3D Properties in the context menu of the selected object
in the Class Library up to the commands for opening the object.

• We added an error message that Plant Simulation shows when you created a new object
with the command Derive and when the new name, that you entered, could not be assigned.

• We enhanced the visualization of the BottleneckAnalyzer in 3D. We replaced the
transparent box with transparent sides with lid and we adjusted the width to the number of
columns.

New and Changed Features in Plant Simulation 13.1

• We renamed the settings under Model Settings > General > Visualization. We added the
setting Ask Each Time to Preferences > General > Visualization.

• We added the folder User Objects to the Class Library and to the Toolbox. Create and
store the objects, which you yourself develop, in this folder.

• We added the folder Objects to the folder into which Plant Simulation is installed. By
default it contains sub-folders with object files for Containers and Transporters. You can
also save object files for re-usable objects which you and your colleagues created.

• We added the button Update All Libraries to the dialog Manage Class Library. You can
use it to update all libraries to the newest version.

• We changed the behavior of when selecting objects in the Toolbox: When you select an
object in the Toolbox while holding down the Ctrl key, the object remains selected in the
Toolbox after inserting it. Thus you can insert several instances of the selected object one
after the other. You can terminate this mode with the right mouse button or with the Esc
key.

Back to What’s New in Tecnomatix Plant Simulation 14

New 3D Viewer Features

Tecnomatix Plant Simulation 14 provides a number of new features.
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New Features in Plant Simulation 14.0

• We added settings for the animation area to the tab MU Animation of the objects with
matrix loading space. The animation area replaces the function Create Paths > Create
Locations of previous versions of Plant Simulation.

• We replaced the setting Auto graphics active for the MUs with the setting Scale
automatically. It adjusts the size and the position of the graphic of the MUs to the
dimension and the booking point of the MU in 2D.

• We added settings for mirroring to the tab Transformation.

• We added settings for the rotation to the tab point cloud. This allows you to set a rotation
with a rotation angle and a rotation axis. In previous versions you could only set the
rotation angle and the point cloud used the pre-defined axis (0,0,-1).

• We added the command Insert Factory Walls.

• We added the setting Obstacle for the worker > Sides to the command Insert Stairs.

• We added the button Obstacles to the tab View of the 3D-Viewer.

• We added the button Adjust Graphics to MU Size to the tab Graphics of the MUs in the
dialog Edit 3D Properties.

• We replaced the command Create Cone with the command Create Cone Frustum.

• We added buttons for moving camera marks up or down in the list of camera marks.

New Features in Plant Simulation 13.2

• We added the attributes _3D.ShowConnections, _3D.ShowExternalGraphics,
_3D.ShowGrid, _3D.ShowPointClouds, and _3D.ShowShadows.

• We added the attribute _3D.getPositionOfObject.

• We added the methods _3D.SelfAnimations.<Animation.play,
_3D.SelfAnimations.playRotation, and _3D.SelfAnimations.playTranslation.

• We added the tab Captions to the dialog Edit 3D Properties of the objects.

• We added the command Show Statistics Report to the context menu of the animatable
objects in 3D.

• We added the command Help on Dialog to the dialog Edit 3D Properties. It opens the
help topic for the dialog. You can then navigate to the help for the different tabs that the
dialog provides.

• We added alternative graphics for Euro pallets of type EUR 2/ISO2, EUR 3, and EUR 6/
ISO0 to the Plant Simulation installation folder > s3d-graphics > Containers.
We use the Euro pallet of type EUR 1/ISO1 as the standard graphic.

• We added a message that Plant Simulation shows when you exchange the 3D graphic of an
object with matrix loading space, such as the ParallelProc, the Container, the Workerpool,
etc. Plant Simulation now asks if you want to use the number of places from the 3D MU
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Animations of the new graphic as the new capacity. This applies when the number of
loading spaces differs between the original graphic and the new graphic.

New Features in Plant Simulation 13.1

• We added the tab Robot Arm Animation to the dialog Edit 3D Properties of the
PickAndPlace Robot. On it you can set if it will be animated with one, three, or with four
axes.

• We added the objects Dropdownlist, CheckBox, and Button to the objects which the 3D
Viewer shows in 3D windows. When you set scaling on the tab Transformation in the
dialog Edit 3D Properties, this does not affect the width and the height in the dialog of
the object in 2D. The 3D Viewer only distorts the graphic of the object and does not change
its dimensions.

• We added the edddison interface.

• We added the sub-command Export Bitmap to the command Export Scene.

• We added the setting Optimize for to the command Insert Rack.

• We added the setting Show sensors to the dialog Edit 3D Properties > Tab Graphics.

• We added the command Show Corner Points to the context menu of the Connector. You
can use it to attach the Connector to another object.

• We added SolidEdge files (*.asm, *.par, *.psm) to the data types that Plant Simulation
can import as graphics.

• We added the method _3D.exportAsBitmap. It exports the designated 3D scene as a .PNG
file.

• We added the methods _3D.addObject and _3D.delete.

• We added the method _3D.SelfAnimations.scheduleTranslation.

Back to What’s New in Tecnomatix Plant Simulation 14

Changed 3D Viewer Features

Tecnomatix Plant Simulation 14 provides a number of changed features.

Changed Features in Plant Simulation 14.0

• We changed how to create rotation paths. You can now select the setting Rotation path
(Lines) instead of clicking the button Create Paths > Create Rotation Path.

• We changed the functions of the command Insert Cylinder. You can now select the
individual parts of the cylinder that you want to create.

• We changed how the 3D Viewer searches for applicable MU animation paths for showing
Workers. This no longer works based on animation path names, for example Default for
the FootPath or #0#1, etc. for the WorkerPool, but based on the consecutive number in
the MU animation attribute as already implemented for MUs on the PickAndPlace robot
or on a Worker. When the 3D Viewer does not find the path with the required number, for
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example the second path to show the second Worker on the WorkerPool, it uses the path
named Default if that path exists.

• We removed the commands Show/Hide Camera Icons and Toggle Camera from the
tab View of the 3D-Viewer.

• We separated inheritance of the state graphics from inheritance of the object graphics
on the tab Graphics. You can now activate or deactivate them separately with the toggle
buttons next to Object graphics and State group.

• We changed the behavior when modifying the orientation of a State group. The last
transformation of the vertical or horizontal state group now does not get lost any more.

• We changed how the 3D Viewer scales. In previous versions you could also enter a
negative scaling factor. From version 14 on we split this into settings for unsigned scaling
(settings for scaling) and settings for mirroring.

• We changed how the WorkerPool in 3D looks. It now looks like this:

As opposed to 2D it only shows a single Worker in 3D. If you would like to see how many
Workers are staying in the WorkerPool, open it in a new 3D window.

• We changed how the command Lock Structure works. It now also prevents you from
inserting graphics.

• We changed the data type of the 3D attributes and the parameters of 3D methods, which
refer to a position or to dimensions. In previous versions the data type was real. From this
version on the data type is length or an array of data type length.
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• We changed the behavior for the first anchor point of an extrusion polycurve. For the first
anchor point you cannot open the dialog Edit 3D Properties.

• We changed the behavior when selecting something in a 3D window. From this version on
this selection is only visible in this 3D window except the selection is an MU instance.

In previous versions this selection was visible in all open 3D windows. If, for example,
you selected a graphic in an open SingleProc, this graphic was marked as selected in all 3D
windows for all SingleProcs which inherit their graphics from this SingleProc or from the
SingleProc from which this graphic inherits. When you selected an object this object was
shown as selected in all windows, for example in an inserted Frame instance as well as in
the Frame class and in all windows which were opened for that object. Now this is only the
case when you select an MU instance, namely the object and not its graphic.

• We activated the buttons for controlling the simulation on the mini toolbar in the 3D
window of an animatable object.

• In Full Screen mode you can now also show the frame rate by pressing the F key and use
the multimedia buttons on multimedia keyboards.

• We changed the behavior when rolling the mouse wheel in the window of a 3D scene.
Plant Simulation now zooms the 3D scene in when rolling the mouse wheel forward. In
previous versions it zoomed the scene out. To facilitate this, we changed the standard
setting under Preferences > 3D > Mouse wheel behavior to Move camera. In previous
versions it was Move scene. The new standard setting is the same as in NX and on Web
sites.

• We added a second optional parameter to the method _3D.exchangeGraphic.

Changed Features in Plant Simulation 13.2

• We enhanced the behavior of the 3D Viewer. You can now combine the functions Align to
Grid and Snap to Grid.

• We enhanced the behavior of the function Align to Grid. It now also applies to graphics.

• We changed the behavior of the feature Show Shadows. You can now only activate it for
objects of type Frame.

• We changed the behavior of the extrusion configuration of the length-oriented objects on
the tab Appearance in the dialog Edit 3D Properties. We renamed the conveyor type
setting Not defined to User-defined.

We moved the settings for defining a user-defined conveyor from a series of sub-dialogs to
the tab Appearance itself.

We limited the values for graphic group IDs in the extrusion configuration to values
between 0 and 10.

• We renamed the following methods: _3D.pauseAnimation to _3D.pause,
_3D.playAnimation to _3D.play, and _3D.resetAnimation to _3D.reset.

• We removed the button Show Preview from the dialog Edit 3D Properties. The
program now shows changed values immediately after changing them.
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Changed Features in Plant Simulation 13.1

• We renamed the tab Extrusion for length-oriented objects in 3D to Tab Appearance.

• We enhanced the behavior of the 3D Viewer for displaying objects of type Display,
Comment, and Variable in 3D windows. The 3D Viewer now shows them with the font size
that you selected in the dialog of the object in 2D.

• We enhanced the behavior of the 3D Viewer for displaying angle-dependent Connectors.
They are now displayed as in 2D, namely depending on the angle between the objects.

• We changed the coordinates with which we define the bounding box of an obstacle for
the Worker:

o From this version on we use the object coordinates. Previous versions used the
coordinates of the graphic nodes.

o The bounding box of the methods _3D.BoundingBoxSize, _3D.BoundingBoxMax,
_3D.BoundingBoxMin, and _3D.BoundingBoxCenter as well as some interactive
functions now excludes all hidden graphics.

• We changed the behavior when calculating the bounding box of the objects in 3D:
Displayed path nodes and objects, which are located on the object, are now excluded from
the calculation.

• We changed what the command Export Graphics exports:

o If you selected an object or a graphic in the active 3D window, the 3D Viewer exports
the selected object or the selected graphic.

o If you did not select anything, the 3D Viewer exports all graphics that are visible in
the 3D window.

• We changed the behavior when Plant Simulation automatically inserts Connectors. The 3D
Viewer now uses the Interface, when you insert an Interface into 3D Frames with visible
contents and move it with the mouse or with keyboard keys.

• We renamed the command Insert Facet to Insert Plate.

• We added four additional settings to the function MU side to attach and we changed the
functioning of the existing settings.

Back to What’s New in Tecnomatix Plant Simulation 14

What's New in Tecnomatix Plant Simulation 13

What's New in Tecnomatix Plant Simulation 13

Tecnomatix Plant Simulation 13 provides a number of new and improved features.

• Important Changes in Plant Simulation 13

• New Features of the Material Flow Objects

• Changed Features of the Material Flow Objects



Chapter 1   What's New

1-22  Stand-alone TopicSet           

• New Features of the Fluid Objects

• New Features of the Information Flow Objects

• Changed Features of the Information Flow Objects

• New and Changed User Interface Features

• New and Changed SimTalk Features

• Miscellany

• New 3D Viewer Features

• Changed 3D Viewer Features

As the program changed at a number of places, you might have to adapt simulation models
you created in previous versions of Tecnomatix Plant Simulation, when you open them in
Tecnomatix Plant Simulation 13.

Back to What’s New

Important Changes in Plant Simulation 13

Tecnomatix Plant Simulation 13 provides a number of new and improved features.

Important Changes in Plant Simulation 13.0

The most important new function in Tecnomatix Plant Simulation 13 is the Worker who
moves freely within the area of the model. This way he is not bound to Footpaths any
more which you insert into your model.

To enable free movement within the area, we added the following functions:

• We replaced the text box Workers can beam to the Workplace with the dropdown
list travel mode in the WorkerPool.

• We enhanced the functionality of most of the 3D objects to allow you to set if these are an
obstacle for the Worker moving freely within the area. You find the setting Obstacle for the
Worker on the Tab Graphics or on the Tab Graphic Settings. For most of the material flow
objects the bounding box is an obstacle for the worker by default.
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• We added the function Insert Barred Area to the 3D Viewer to create areas which the
Worker can enter but should not be, for example the pivoting range of a crane.

Important Changes in Plant Simulation 12.1

Tecnomatix Plant Simulation 12.1 provides a number of new and improved features.

• We changed the user interface theme of Plant Simulation 12.1 to match the standard
Siemens PLM theme. This affects the look-and-feel of the entire application, i.e., of the
main program window, of the docking windows, of the object windows, and of the dialog
windows.

Note that we have not replaced all screenshots of dialogs and windows in the Online Help
yet.

• We introduced SimTalk 2.0. It’s features make programming methods in Plant Simulation

faster, easier, and less error-prone. You can activate it by clicking New Syntax 
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on the Tools ribbon tab of the Method. If you want to use SimTalk 2.0 syntax for all new
Methods which you are going to program, activate New Syntax in the Method class in the
Class Library. Changes caused by SimTalk 2.0 also affect how the dialog Show Attributes
and Methods displays the signature of attributes and methods. There turn value of a method
is now displayed to the right of the keyword -> instead of to the right of the colon (:).

You can select if you want to use the SimTalk 2.0 or SimTalk 1.0 notation
for each and every of your Methods. You can also freely mix SimTalk 2.0 or
SimTalk 1.0 notation in your simulation models. There is no need to reprogram
your existing source code.

Clicking  for an existing Method, which you created in SimTalk 1.0
notation, automatically converts the source code to the correct SimTalk 2.0
notation.

To convert the source code of all existing Methods in a simulation model to the new
syntax, hold down the Shift key, click the object Basis in the Class Library with
the right mouse button, and click Convert All Methods to New Syntax

• We only deliver the 64-bit version of Plant Simulation. We do not provide a 32-bit version
any longer.

• We added support for the following 3D graphics formats to the command Import Graphics:
Parasolid Text, Parasolid Binary, PLMXML, STEP, IGES, and Catia V4.

These formats require a Professional, an Educational, a Research, an Application,
or a Standard License.

Back to What’s New in Tecnomatix Plant Simulation 13

New Features of the Material Flow Objects

Tecnomatix Plant Simulation 13 provides a number of new features.

New Features in Plant Simulation 13.0

• We extended the functionality of most of the 3D objects to enable you to set if these
objects are an obstacle for the Worker who moves freely within the area. You find the
setting Obstacle for the Worker on the Tab Graphics or on the Tab Graphic Settings.

• We added the method isUp to the AngularConverter.

• We added the methods statTspUnplannedCount, statTspUnplannedDelta,
statTspUnplannedMu, and statTspUnplannedTime to the Transporter.

New Features in Plant Simulation 12.2

• We added the setting Base height to the Tab Curve of the length-oriented objects. As
opposed to previous versions of the program, the Base height can now be inherited,
meaning that you can define it once in the class instead of having to define it for each
instance individually. It is mainly used in the 3D Viewer. Here the Z-coordinate defines
the floor of the installation and the Base height defines the distance of the legs of the
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conveyor from the floor. By changing the setting ∆Z in the Segments table, you can add

an additional offset. The setting ∆Z also affects the simulation time in Plant Simulation 2D.

To facilitate these changes, we also changed the Segments table, the Context Menu of
Curved Objects, and we added the methods getCurveSegments and getCurveSegments. The
methods replace the attribute SegmentsTable.

The changes above also affect the 3D Viewer. We replaced the settings Visualize, Edit,
and Extend in the group box Curve with the button Segments. It opens the segments table
of the object in 3D, which now is the same as in 2D.

We removed support for the 3D attribute _3D.ExtPolycurve. We added the methods
3D.getExtSegments and 3D.setExtSegments instead.

New Features in Plant Simulation 12.1

• We added the text box Exit control to the Tab Controls of the Store.

• We added the text box Capacity to the Converter.

• We added the Exit strategy > Carry part away to the  Store. This enables a  Worker to
pick a part up at the  Store and carry it to another station.

• We added the setting Width to the  length-oriented objects.

• We added the attributes ObjectAngle and ObjectMirrored to the  curved objects.

• We added the method getObservers to objects which can have observers.

• We added an optional parameter to the method setUpFor.

• We added an optional parameter to the Constructor control.

• We added the methods getCurrentAngle, getLastDestination, and isRotating to the
PickAndPlaceRobot.

• We added the method findPart to the ParallelProc, the Store, and the  Container.

• We added optional parameters to the method createFailure.

• We added a number of statistics methods to the MUs, for example statProdFailTime, etc.,
statStoreFailTime, etc., and statTranspFailPortion, etc.
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Back to What’s New in Tecnomatix Plant Simulation 13

Changed Features of the Material Flow Objects

Tecnomatix Plant Simulation 13 provides a number of changed and improved features.

Changed Features in Plant Simulation 13.0

• We changed and extended the following functions for setting curved objects:

o After clicking on an existing object, Plant Simulation now also uses the angle from
the previous object as start tangential angle of the new object when the predecessor
object was displayed with its icon.

o When setting a straight segment by clicking on an existing object, Plant Simulation
uses, depending on the mouse position, either the angle of the object or +- 90 degrees
to this angle as the start tangential angle of the new object.

o When setting a curve segment without clicking an existing object, Plant Simulation
now proceeds as follows: When you enter an angle for straight segments, Plant
Simulation uses this angle as start tangential angle of the new object. When you hold
down the Ctrl key, Plant Simulation uses, depending on the mouse position, 0, +-90
degrees or 180 degrees as start tangential angle.

• We changed when the processing time is evaluated. From now on no Workers are
requested when you entered a processing time of 0. For this reason the processing
time will now be calculated when the MU enters the object or when setting-up is finished,
not when the Worker is requested or when he arrives as in previous versions.

If you would like to request a Worker in spite of a processing time of 0 enter a
processing time that is slightly greater than 0, for example 0.001.

• We changed the user interface color of Plant Simulation from a dark teal to a dark cyan.

• We changed the behavior of the user-defined ribbon. The 3D Viewer now also shows
and activates it when you click on a Frame for which a user-defined ribbon tab is
defined in Plant Simulation 2D.

• We changed the layout of the Tab Attributes of the MUs. In addition it now also shows the
absolute position of the booking point.

• We changed the behavior when manually inserting MUs on Line, Track, and
TwoLaneTrack. In previous versions Plant Simulation always inserted the MU at the end of
the object. Now it inserts the MU at the position of the mouse pointer on the object.

• We changed the behavior when moving an MU with the method transfer. The MU is now
moved with the command transfer after unblocking it, not with the command move.

• We renamed the method movingAcceleration of the MUs to currentAcceleration.

• We added the attribute CurrentSpeed to the Line. For the Line, the attribute is not
observable.

• We renamed the method movingSpeed of the MUs to currentSpeed. The method now also
applies to the Transporter as opposed to previous versions which provided the attribute
CurrentSpeed. For the Transporter you can also set the current speed.
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• We changed the behavior of the object Cycle. From now on you cannot drag two objects at
the same time onto the object Cycle with the mouse anymore and drop it there.

Changed Features in Plant Simulation 12.2

• We changed the Segments table so that it does not contain rotation or mirroring after a
rotation or mirroring any more. The rotation is stored in the attribute ObjectAngle and
mirroring is stored in the attribute ObjectMirrored. This allows to keep inheritance of the
definition of the segments even when one or more segments are rotated or mirrored.

• We changed the behavior of the method setRoute of the Transporter. It now also accepts
material flow objects other than objects of type Track. In previous versions these objects
were allowed as destination of the route, but not as objects along the way. When assigning
a route, which contains such objects with setRoute, then the Transporter passes these
objects on its way to the destination. While automatically computing a route, Plant
Simulation only takes Tracks and TwoLaneTracks into consideration.

• We changed the behavior of the methods insert, move, and transfer of an MU that is
located on a Converter. These cannot be called with an index for the successor any longer.
In previous versions the index was ignored when you passed one and Plant Simulation
showed a warning in the Console. From this version on the Method Debugger will be
opened with an error message instead.

Changed Features in Plant Simulation 12.1

• We changed the behavior of Transporters that were stopped by Plant Simulation, for
example in an Exit control. When you change the direction of movement by changing
the setting Backwards of a Transporter, now the  Transporter immediately starts moving.
In previous versions you had to make the  Transporter start moving again by entering
Stopped := false. As a result of this change you may have to adjust your model by
Stopping the Transporter before changing the state of Backwards. Otherwise the
Transporter starts moving in the previous direction in order to reduce its Speed to 0
before being able to turn around.

• We changed the behavior when opening the Blocked exit of a material flow object. In
previous versions the Line or the Transporter started accelerating again with the Speed
that these objects had before. Now they accelerate starting a speed of 0.

• We limited the Capacity of MUs to 1 million storage places per MU and we limited the
Capacity of Stores and ParallelStations to 10 million places per object to prevent slowing
down the computer by using up too much RAM.

• We enhanced the behavior of the Assembly station. For the setting Attributes > Assembly
table > MU Types the Worker can now deliver mounting parts to the Assembly station
without you necessarily having to connect the Assembly station with the station which
provides the mounting parts.

• We changed the behavior of the method getDestination of the PickAndPlaceRobot. It now
also returns a destination object when it rotates to the destination without transporting a
part.

• We removed the view option Enlarge Objects from the General ribbon tab of the
Frame.
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• We enhanced the behavior of the method removeObserver. You can now also enter void
as second parameter. This deletes all  observers which point to nonexisting methods.

• We changed the behavior of the Exit strategy > Carry part away. The Exit strategy will
be executed once only when the part is moved onto the Worker and when Exit control
once is activated.

Back to What’s New in Tecnomatix Plant Simulation 13

New Features of the Fluid Objects

Tecnomatix Plant Simulation 13 provides a number of new features.

New Features in Plant Simulation 13.0

• We added a function allowing you to add the MaterialsTable to the objects DePortioner
and Mixer with drag and drop.

• We added the method contentsList to the fluid objects.

New Features in Plant Simulation 12.2

• We added the object DePortioner.

• We added the fluid objects to the objects which the LockoutZone can control.

New Features in Plant Simulation 12.1

• We added Sensors to the Tank. You can select if the amount of material in the Tank has
Exceeded or Underrun the sensor level.

• We added the setting Outflow rate to the Pipe.

• We added the methods entranceOpen and timeUntilEntranceOpen to the Mixer.

Back to What’s New in Tecnomatix Plant Simulation 13.

New and Changed Features of the Resource Objects

In Tecnomatix Plant Simulation 13 we provide these new and changed features:

• We added the text box Average traveled distance and the method
statAverageTraveledDistance to the WorkerPool.

• We replaced the text box Workers can beam to the Workplace with the dropdown
list travel mode in the WorkerPool.

Back to What’s New in Tecnomatix Plant Simulation 13
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New Features of the Information Flow Objects

Tecnomatix Plant Simulation 13 provides a number of new features.

New Features in Plant Simulation 13.0

• We added a new function to open the Method from which the current Method inherits its
source code. To do so, hold down the Shift key and click the button Open Origin in the
current Method or in the Method Debugger.

New Features in Plant Simulation 12.2

• We removed the Font selection from the settings of the Method Editor. The Method Editor 
and the Method Debugger  now use the font Consolas in different fixed sizes between 6
and 72 points.

You can increase or decrease the font size by holding down the Ctrl key and by rolling
the mouse wheel forward and backward in the Method Editor  or the Method Debugger
window. When you change the font size with the mouse wheel, Plant Simulation saves
this as the new preference and uses it when you start the program the next time. Plant
Simulation uses the changed font size in all open Method windows, not just in the one in
which you rolled the mouse wheel.

Instead of rolling the mouse wheel, you can also use these key combinations:

Ctrl plus + increases the font size

Ctrl plus 0 resets the font size to the standard size of 10 points

Ctrl plus - decreases the font size

• We added horizontal scrolling in the Method Editor by holding down the Shift key and by
rolling the mouse wheel.

• We added the command Show Object to the context menu of the selected object in the
source code in the Method Editor and in the Method Debugger. The command opens the
Frame in which the object is inserted and selects the object in the Frame.

If the selected object references another object, for example with a Variable, the command
shows the referenced object, not the referencing object! The context menu of the Variable
in the Method Debugger also provides the command Show Object.

• You can now add an integer value to a string. This applies to SimTalk 1.0 as well as to
SimTalk 2.0.

Example: param obj : object ->  string
return obj.Name + obj.XPos

• We added the method appendRow to the  TableFile.

• We added an optional parameter to the method createNestedList of the CardFile,
createNestedList of the StackFile and QueueFile, and createNestedList of the TableFile. It
allows you to enter the name of the list/table to be created in the designated row/cell.

New Features in Plant Simulation 12.1

• We added the method readXMLString to the TableFile.
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• We added renamed the control structures, compare Insert Control Structure. Note that they
create SimTalk source code.

Back to What’s New in Tecnomatix Plant Simulation 13

Changed Features of the Information Flow Objects

Tecnomatix Plant Simulation 13 provides a number of changed and improved features.

Changed Features in Plant Simulation 13.0

• We extended the function Auto Complete of the Method. When you insert a function or a
Method with parameters into a Method, Plant Simulation now shows the status bar. The
status bar shows the signature of the function/Method and thus makes entering the required
parameters easier. Plant Simulation hides the status bar again when you type in the closing
parenthesis or when you press the Esc key.

• We replaced the methods getFormatData and setFormatData of lists and tables with the
method copyFormatTo.

• We changed the behavior of the Options (Syntax-controlled Indentation, Show Line
Numbers, View) on the Tools ribbon tab in the Method Editor: When you change one of
these settings, this change now applies to the entire Plant Simulation session for all newly
opened Methods.

When you deactivate Toggle Outline in the Method Editor for example, it now remains
deactivated when opening an additional Method or when reopening this Method in the
current Plant Simulation session. These changes do not affect the preferences.



What's New

          Stand-alone TopicSet  1-31

• We changed the behavior when changing the font size in the Method Editor. When
changing the font size with the mouse wheel, this now does not affect the Preferences
any more. The Method only uses the changed font size until you change it the next time
or until the end of the current session for all Methods which you open afterwards. Changing
the font size does not affect any opened Methods at all.

Changed Features in Plant Simulation 12.2

• We changed the behavior when a Method accesses outdated, i.e., no longer officially
supported attributes, methods, and functions. As opposed to previous versions Plant
Simulation no longer shows a message in the Console. Instead, you can use the command
Find Outdated Functions on the Debugger Ribbon Tab to find outdated attributes, methods,
and functions.

• We changed the behavior of the TableFile. When you accessed a cell via a column or
row index of data type string, Plant Simulation only matched the case when the Fast
index access was activated. From now on Plant Simulation ignores case sensitivity.

• We changed/enhanced the behavior of the SQLiteInterface. If you do not enter a File Name
for the database, Plant Simulation creates it in memory. This then is the same as if you had
entered :memory:.

Changed Features in Plant Simulation 12.1

• We removed the LED for Methods that are suspended by a wait-instruction or by a sleep-
instruction. The Methods now shows the same LED as for suspended Methods.

• We changed the behavior of the method createNestedList of the CardFile. In methods,
which use  SimTalk 2.0 syntax, the method createNesteList  does not insert the new sublist
between already existing sublists, but overwrites the sublist without moving existing
sublists one row downwards.

Back to What’s New in Tecnomatix Plant Simulation 13

New and Changed Features of the User Interface Objects

Tecnomatix Plant Simulation 13 provides a number of new and improved features.

New Features in Plant Simulation 13.0

We added the attribute TocLevels to the HtmlReport. You can use it to set the number of levels
for the table of contents.

New Features in Plant Simulation 12.1

In Tecnomatix Plant Simulation 12.1 we added or modified these features of the user interface
objects.

• We added a function to Display a Picture of a 3D Scene to the HtmlReport.

• We changed a number of functions of the HtmlReport when you add objects on the Tab
Content:
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o When the text cursor is located within an object reference ([…]), Plant Simulation
opens the dialog Object Parameters for entering the object parameters of the object

within the square brackets, when you click Add Object  .

o When the text cursor is located within an object reference ([…]), Plant Simulation
opens the dialog Select Object preset to the path detected within square brackets,

when you hold down the Shift key while clicking Add Object 

o When the text cursor is located within a picture reference ([!…]), Plant Simulation
first opens the dialog Open File and then the dialog Object Parameters for the

path within square brackets when you click Add Image 



What's New

          Stand-alone TopicSet  1-33

o When the text cursor is located within a picture reference ([!…] ), Plant Simulation
first opens the dialog Open File Object and then the dialog Object Parameters
preset to the path detected within square brackets when you hold down the Shift key

while clicking Add Image 

o When you select a Frame to be inserted, which provides the user-defined attribute
StatisticsObject, the dialog Object Parameters shows the available statistics
functions.

Back to What’s New in Tecnomatix Plant Simulationn 13

New and Changed SimTalk Features

Tecnomatix Plant Simulation 13 provides a number of new and improved features.

New and Changed Features in Plant Simulation 13.0

• We added the function computeSHA3Hash.

• We added the function strHash.

• We added the function _3D.ShowSensors.

• We changed what the function closeAllWindows does. As opposed to previous versions it
now also closes 3D windows.

New and Changed Features in Plant Simulation 12.2

• We added the function setRandomSeedCounter.



Chapter 1   What's New

1-34  Stand-alone TopicSet           

• We added the functions regex_replace and regex_search to search and replace regular
expressions.

• We added a function to define Default Arguments in SimTalk 2.0.

• We added the attributes X, Y, and Z to the one-dimensional arrays which are of data type
integer, real, or length and which have a fixed dimension of two or three elements.

• We changed the behavior of the method str_to_method and we added a second, optional
parameter.

New and Changed Features in Plant Simulation 12.1

• We introduced SimTalk 2.0. It’s features make programming methods in Plant Simulation
faster, easier, and less error-prone.

• We added the function splitStringToNum to the functions for manipulating strings.

• We added the function atan2 to the trigonometric functions.

• We added the function deleteValue to the one-dimensional arrays.

• We enhanced the function setMUTraceRouteMethod. You can now set several MU-Trace-
Route-Callback-Methods. Up until version 12 you could only set a single Method. To do
so, you can enter an array of objects.

When you save a Frame or a folder as an .obj file Plant Simulation now also saves the list
of the assigned  MU-Trace-Route-Callback-Methods to the .obj file. This only applies to
those callback methods whose Method objects are also written to the .obj file. If you
load the .obj file into another simulation model, Plant Simulation adds the MU-Trace-
Route-Callback-Methods in the .obj file to the callback methods contained in the model.

Back to What’s New in Tecnomatix Plant Simulation 13

Miscellany

Tecnomatix Plant Simulation 13 provides a number of new and improved features.

New and Changed Features in Plant Simulation 13.0

• We added the function Find a Command. Enter words and phrases about what you want to
do next and quickly get to features you want to use or actions you want to perform into the
text box Find a Command.
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• Plant Simulation now uses the SPLM license mechanism version 8.0.1. For this reason
Plant Simulation now requires the license server version 8.0 or higher.

• We removed support for the start option -StartPage.

• We removed the View Option > Show Animation Points of the Frame.

• We removed the Preference/Model Setting > Modeling > Show Animation
Points.

New and Changed Features in Plant Simulation 12.2

• We added the function setVisible to the COM Interface. When Plant Simulation is created
as a COM server it is invisible by default. You can use setVisible to make it visible.

• We enhanced the behavior of the feature Find Outdated Functions on the Debugger
ribbon tab: In addition to finding outdated attributes, methods, and functions in the source
code of Methods, it also finds observers of outdated attributes, for example observers of
the attribute ChannelID. For such observers Plant Simulation opens a window containing a
list of all outdated attributes for the observers. When you double-click an entry in the list,
Plant Simulation opens the dialog Edit Observers for the observed object, as long as only
a single observed object exists. If several observed objects exist, Plant Simulation opens a
window with a list of all observed objects. To open the observer window for the respective
object, double-click the respective entry in the list.

• We changed the behavior when you modify the Axes origin X and the Axes origin Y
of the Frame. When you change the axes origin, Plant Simulation now keeps the 3D
coordinates and changes the pixel coordinates. Plant Simulation checks if your changes
create allowed pixel coordinates. It only changes them if that is the case.

• We changed the behavior when you modify the Scaling Factor of the Frame. When you
change the scaling factor, Plant Simulation now keeps the 3D coordinates and changes
the pixel coordinates. Plant Simulation moves the axes origin if your change would create
negative pixel coordinates.
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• We changed the behavior when  zooming the contents of a Frame: In previous
versions you could hold down the right mouse button and drag a marquee over the objects
of interest. Now you have to hold down Ctrl + Shift and drag a marquee with the left
mouse button.

• We changed the behavior of user-defined attribute methods, which are deleted while
they are being executed. Method execution is now terminated immediately, it will not be
continued. Compare the following examples:

o Suppose that an MU has a user-defined attribute method, which was suspended via
a waituntil instruction. Then, the MU is deleted in the Drain, which naturally also
deletes its user-defined attributes. Thereupon the  Method is deleted from the list of
suspended methods and method execution is terminated, i.e., the instructions after
the waituntil instruction will not be executed. If the attribute method was called from
another Method, execution of this Method will be continued. When the attribute
method had a return value, the value, which the implicitly existing local variable result
had at this point in time, will be returned to the calling Method.

o Suppose that an MU has a user-defined attribute method, which is called by the
entrance control of a SingleProc. The attribute method in turn calls a  Method
that is inserted in the Frame. This Method deletes the MU with the statement
SingleProc.cont.delete. Both the execution of the attribute method and of the Method
called by it are terminated immediately. The return value of the attribute method (or
VOID if no return value was declared) will be returned to the entrance control,
whose execution is continued.

New and Changed Features in Plant Simulation 12.1

• We added the setting Visualization to the tab General of the Model Settings. It sets how
Plant Simulation creates the new simulation model.

• We added the setting OpenGL Version to the tab 3D of the Preferences.

• We added the method unshare to the user-defined attributes and to the object Variable.

• We changed the layout of the Tab Importer and integrated the failure importer into it. It
now shows the Sub-tab Processing, the Sub-tab Set-up, and the Sub-tab Failure.
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• We replaced the attributes ImporterActive and FailImporterActive with the attribute
imp.Active/ failImp.Active. We added the attribute setupImp.Active for the set-up importer.

• We changed the notation for the Tolerance for about equal (~=) comparison. Instead of
using == for the operator, we now use ~=.

• We enhanced the functions Open Origin and Open Class. When you hold down the Shift
key while clicking the buttons, Plant Simulation shows the location of the origin of the
object or the location of the class of the object respectively.

• We removed the setting User interface concept. We do not provide the setting Menus
and Toolbars any more.

• We removed the button Hide All Dialogs from the Window ribbon tab.

• We removed the tab Communication from the dialog User-defined Attributes of the
objects.

• We removed support of the graphics formats .ppm and .ppm_raw for the command Import
Bitmap File.

• We moved the user-defined attributes of the object GaOptimization from the Tools menu
to the Tab User-defined Attributes.

• We replaced the attribute IconAngle with the attribute ObjectAngle.

• We replaced the attribute IconRotation with the attribute ObjectMirrored.

• We added the Tab 3D to the MultiPortalCrane.

• We added the methods synchronize and unsync to the MultiPortalCrane.

• We added the attribute Load by capacity to the CrossSlidingCar.

• We extended the functionality of the Student License. You now can also load models,
which you created with a Student License in any of the commercial licenses.
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Back to What’s New in Tecnomatix Plant Simulation 13

New 3D Viewer Features

Tecnomatix Plant Simulation 13 provides a number of new features.

New Features in Plant Simulation 13.0

• We added new 3D graphics for a number of material flow objects, which represent these
objects more realistically in your installation.

To replace existing graphics in a model, which you created in a previous version of
the program, with the new graphics, select the respective graphic and select Exchange
Graphics. Navigate to the folder 3D > BasicObjects and select the new graphic of the
object.

In addition we offer alternative graphics for special applications for the Buffer, the Sorter,
and the Transporter. To use one of it, select one of these objects in the 3D window, click
Exchange Graphics, and select an alternative graphic.
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• We extended the functionality of most of the 3D objects to enable you to set if these
objects are an obstacle for the Worker who moves freely within the area. You find the
setting Obstacle for Worker on the Tab Graphics or on the Tab Graphic Settings.

• We added the Tab Graphic Settings for graphics. Here you can set if the graphic is an
Obstacle for the Worker or not.

• We added the functions Insert Barred Area and Insert Stairs.

• We added the Tab Appearance of the Store. Here you can set its configuration for its
appearance in 3D.

• We added the Tab Material to the Worker. You can now add a material to them, just as
you can do for the MUs, which applies to all graphics for which no other material applies.
As opposed to the MUs you cannot use a 2D material for the Worker, when no material is
defined, as the 2D vector graphics material that is required for does exist.

• We added the Tools Menu to the dialog Edit 3D Properties of the Frame.

• We added the attribute _3D.TransformationMatrix.

New Features in Plant Simulation 12.2

• We added the button Add Camera to the View ribbon tab. This button replaces the button
Capture Current View in the dialog  Path Anchor Points.

• We added new mouse button combinations to move or zoom the scene with the mouse:

• To zoom the scene in Planning View, hold down the Shift key and the right mouse
button and drag the mouse.

• To move the camera backwards and forwards in normal 3D view, hold down the Shift key
and the right mouse button and drag the mouse.

• We added key combinations for moving the camera in the scene:
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To do this Do this

Move the camera backwards and forwards
in normal 3D view

Hold down the middle and the right mouse
buttons and drag the mouse

Move the camera up by 10 cm Press Shift+Z on the keyboard

Move the camera down by 10 cm Press Z on the keyboard

Move the camera left by 10 cm Press Q on the keyboard

Move the camera right by 10 cm Press E on the keyboard

• We added a function for showing information about the open scene. To do so, press the F
key on the keyboard.

• We added CAD Layout Files (*.dgn, *.dwg, *.dxf) to the files types which the command
Import Graphics can import.

• We added the commands Controls and Edit User-defined Attributes to the Context Menu of
the Selected Animatable Object in the 3D Scene.

New Features in Plant Simulation 12.1

• We added the command Insert Rack to the command Edit > Insert Shape.

• We added the text box Width to the settings of the  conveyors.

• We added the function _3D.createBox to create a box via  SimTalk.

• We added the command Planning View to the View ribbon tab.

We removed the command Projection from the View ribbon tab.

• We added the command Generate SimTalk Code and Copy to Clipboard to the command
View > Camera Marks.

• The command also copies the corresponding SimTalk code to the clipboard. You can then
paste this code into a Method object to set the material of another graphic.

•

We added the buttons Copy the Current Material Settings  and Paste a Previously

Copied Material  to the tab  Material.

The command  also copies the corresponding  SimTalk code to the clipboard. You
can then paste this code into a  Method object to set the material of another graphic.

• We added the function Locked to graphic groups.
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• We added the command Calculate Angles to the context menu of the objects
PickAndPlace Robot and Turntable in the 3D Viewer.

• We added the methods F3DRecordVideo, F3DFinishVideo, and F3DPauseVideo for
recording videos in the 3D Viewer.

• We added the function _3D.setGraphicTransformationMatrix.

• We added key shortcuts to Manipulate Objects in the 3D scene.

• We added the command Find Object to the Context Menu of the Opened 3D Object.

Back to What’s New in Tecnomatix Plant Simulation 13

Changed 3D Viewer Features

Tecnomatix Plant Simulation 13 provides a number of changed and improved features.

Changed Features in Plant Simulation 13.0

• We changed how the 3D Viewer inserts materials. You can now also insert a material from
the Clipboard into the Tab Material when the material is not active. Then the 3D Viewer
automatically activates a material that was deactivated before.

• We changed the behavior of the MU Animation of Container and Transporter with
matrix loading space and with automatically generated graphics. The 3D Viewer
distributes the MUs on these objects now automatically and ignores existing MU animation
paths.

For the Store the 3D Viewer also distributes the MUs automatically and ignores existing
MU animation paths.

You can activate and deactivate the automatically generated animation graphics jointly
with the automatically generated graphics with the checkbox Auto graphics active on the
Tab Appearance of the MUs or Auto graphics active on the Tab Appearance of the Store.

• You can now subsequently change the settings of a Box, a Shelf, a Barred Area and a
Fence which you insert into your simulation model in version 13. To do so, click the shape
with the right mouse button and select Edit 3D Properties.
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• We changed the behavior of the command Insert Rack. The topmost shelf is now included
in the amount of shelves (board count). In the example below the rack has four shelves.

• We changed the behavior of the 3D Viewer when it could not import a Jt file because that
Jt file originated in a not supported Jt version. Now the error message points this out. If you
imported the file with a Method it still returns -1.

• We changed the behavior of a model which you created in 3D Only mode: Now Plant
Simulation moves the axes origin, if this is possible, when inserting or moving an object
would create invalid pixel coordinates. In previous versions Plant Simulation moved the
object in such a way that the pixel coordinate was located within the valid area and thus
changed the 3D coordinate if an invalid pixel coordinate would have resulted.

• We changed the behavior of a model which you created in 3D Only mode. Then the dialog
Show Attributes and Methods does not show these attributes and methods of the
objects any more:

Method/Attribute
All objects
maximizeWindow
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Method/Attribute
XPos
YPos
setPosition
setXYWH
getXYWH
Icons
setCurrIconFromClipboard
putIconToClipboard
setIconFromFile
saveIconToFile
createIcon
deleteIcon
CurrIcon
CurrIconNo
existsIcon
turnIcon
resetIcon
mirrorY
mirrorX
inheritSizeAndOrientation
setPixel
getPixel
CurrIconTransparent
redraw
openImg
openImg
getIconSize
setIconSize
ObjectAngle
ObjectMirrored
getRefPoint
setRefPoint
getBoundingBox
StatusWithIcons
RotateAroundRefPoint
RotateMUs
NumAnimationEvents
getAniPoints
setAniPoint
setAniLine
moveAniPoint
delAniPoint
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Method/Attribute
delAniPoints
linkAniPoint
unlinkAniPoint
DisplayPanel
Frame
AxesOrigin
drawLine
drawRectangle
drawEllipse
drawText
eraseLayer
eraseAllLayers
redraw
setXYOrigin
rearrange
setBackgroundImage
copyBitmapToClipboard
selectContents
BackgroundColor
ScalingFactor
ZoomFactor
ShowObjectNames
ShowObjectLabels
ShowDisplayPanels
RepresentationMode
ShowObjectLabels
setRepresentationArea

• We changed the behavior when inserting a new graphic. When you select an invisible
graphic group as the insertion target, Plant Simulation now makes this graphic group
visible. When the visibility of the respective object was inherited, Plant Simulation asks if
you want to cut inheritance of the graphics.

• We changed the label of the check box Hide this object in the representation of the
location on the Tab Graphics to Exclude from Show content of the location.

We renamed the attribute _3D.HideInRepresentationOfLocation to
_3D.ExcludeFromShowContentOfLocationon.

Changed Features in Plant Simulation 12.2

• We renamed the tab Auto Graphics of the dialog  Edit 3D Properties to Tab
Appearance and changed some of its functions:

o You can now define materials for all MUs, not only for MUs with an automatically
generated graphic.
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o We changed the group labels Override 2D vector graphic color and Assign a
material to Material active.

o We changed the names of the attributes starting with _3D.Autographic... to
3D.MaterialActive, 3D.MaterialAmbientColor, 3D.MaterialDiffuseColor,
_3D.MaterialEmissiveColor, 3D.MaterialActive, 3D.MaterialShininess,
_3D.MaterialSpecularColor, and 3D.MaterialTransparency.

• We changed the behavior of the 3D Viewer. The dialog Edit 3D Properties can only be
open for an object or for a graphic once, not several times simultaneously.

• We changed the behavior of the 3D Viewer. When you clickEdit and Apply on the tabs
MU Animation, Self Animation, or Camera Animation, paths now remain displayed.

• We changed the behavior of the 3D Viewer. The tabs MU Animation, Self Animation,
or Camera Animation now show the path type Generated in the column Type instead
of the column Generated for animation paths which the 3D Viewer created and which
you cannot edit.

• We changed the behavior of the 3D Viewer. To confirm the current changes to an
animation path in the dialog Edit Path Anchor Points, you now click the new button
Apply in the dialog. In case the path is displayed at the moment, this also updates the
visualization of the path.

• We changed the definition of the Reduction level when you optimize a graphic.

New name Old name Results in

Low Super a low reduction level, a high level of detail

Super Low a great reduction level, a low level of
detail

• We changed the behavior of the 3D Viewer. You now enter the setting Screen coverage
threshold in pixels instead of one-hundred-thousandth of the window area.

• We simplified the layout and the settings in the dialog Optimize Selected Graphic. You can
now use all of the provided optimization strategies at the same time instead of one setting
only as in previous versions.

• We simplified the layout and the settings in the dialog Create Rotation Path. You can now
define the path via the r instead of the start position. The  3D Viewer now automatically
computes the number of steps for the path.

• We simplified the layout and the settings in the dialog Create Locations.

• We changed the behavior of the 3D Viewer. When playing a camera animation in the
dialog Fly on Path, the tab Camera Animation of the dialog Edit 3D Properties,
or via  SimTalk commands, the 3D Viewer automatically terminates the camera animation
when reaching the end position. You can then edit the camera setting again with the mouse.

• We changed the behavior of the 3D Viewer. You can now define vertical curve segments
for a length-oriented object. This only works when the tangential angle is 0° for arriving
and departing segments in all directions.



Chapter 1   What's New

1-46  Stand-alone TopicSet           

• We changed the behavior of the 3D Viewer. You can now insert vertical curve segments
into polycurves with the mouse. To do so, proceed as follows while inserting curved object,
compare Edit a Curved Path with the Mouse:

o Press and hold down the Up arrow on the keyboard to insert a curve pointing
upwards in the Z dimension. Press and hold down the Down arrow to insert a
curve pointing downwards in the Z dimension.

o Enter the radius and the angle of the segment into the dialog Edit Parameter of
Curve.

o Click the mouse in the scene to insert the segment.
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• We changed the behavior of the 3D Viewer. Scaling of a 3D object now only applies to its
own graphics, not to the simulation objects contained within. Contained animatable objects,
on the other hand, are scaled as they are part of the graphic. This way neither the visible
contents of a scaled  Frame nor MUs located on scaled objects are scaled. The graphics of
an object are now shown on each hierarchy level according to its scaling, ensuring that the
proportions which you selected are visible everywhere.

• We changed the behavior of the 3D Viewer. When you load graphics, except in the
format s3d, into your simulation model, the 3D Viewer now removes suffixes in the
format .<extension>;<no>;<no> from the imported node names. This matches the naming
conventions which TcVis shows when loading the same files. In addition the 3D Viewer
now automatically removes empty group nodes.

• We changed the behavior of the 3D Viewer. You can now also activate the Planning
View for objects other than  Frames and  folders.

• We changed the behavior of the  3D Viewer. The setting if a 3D window shows shadows
or not is now saved to the model file.

•

We replaced the button  on the tab Graphics of the dialog Edit 3D Properties

with the button .

• We replaced the methods  _3D.connectPositions/_3D.disconnectPositions
and _3D.connectRotations/_3D.disconnectRotations with the attributes
_3D.PositionsConnected and _3D.RotationsConnected.
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• We removed the setting for activating inheritance of the position for the class of an
object in the dialog Edit 3D Properties.

• We removed support for the method  _3D.disconnectPositionsAndRotations.

Changed Features in Plant Simulation 12.1

In Tecnomatix Plant Simulation 12.1 we changed or improved these features of the  3D Viewer:

• We enhanced the functionality of the length-oriented objects in the  3D Viewer: You can
now activate or deactivate the connection of the rotations in 2D and 3D independent of the
connection of the positions.

• We enhanced the  Drag-and-Drop function in the 3D Viewer: You can now duplicate
3D objects and graphics in 3D windows with Drag-and-Drop. When you drag a graphic
from one 3D window to another or when you want to duplicate generated graphics, the 3D
Viewer allows you to select the graphics group to which it adds the new graphic. If you do
not select a graphics group, the  3D Viewer adds it to the graphics groups of its original
object.

• We enhanced the Drag-and-Drop function in the 3D Viewer: You can drag a 3D object or
a 3D graphic into the Method editor and drop it there to insert the path to this 3D object or
3D graphic.

• We enhanced Editing path anchor points in the dialog Path Anchor Points. You can
now also double-click the row of the anchor point, whose values you want to change in the
list in the dialog.
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• We integrated the setting for selecting the Graphic group into the dialogs for creating
shapes.

• We changed what the attribute _3D.Position does. It now shows the local positions for MU
instances which are calculated by the animation. It now also is available for MU classes.

• We changed how you define an extrusion profile with the attribute
_3D.ExtConfiguration.

• We added the attributes _3D.AniRotationAxis and _3D.AniRotationCenter.
They now define the rotation axis and the rotation center used in the method
_3D.<Type>Animations.scheduleRotation. In previous versions you used the attribute
_3D.Rotation to set the rotation axis and the rotation center. This resulted in the following
changes:

o The attribute _3D.Rotation now only returns an array of four values, excluding the
rotation center.

o The Tab Transformation in the dialog  Edit 3D Properties does not contain settings
for the rotation center any more.
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o The Tab Self Animation now has settings for the rotation axis and for the rotation
center of the object.

o The  Turntable now uses the rotation center you set on the tab Self Animation. In
previous versions it used the center you set in the attribute  _3D.Rotation.

o An anchor point of an animation path of type Lines, compare Edit Path
Anchor Points, now only contains 8 instead of 11 values. You can still set
paths with 11 anchor points in the methods _3D.<Type>Animations.setTable and
_3D.<Type>Animations.<AnimationPathName.setTable, they will ignore the three
values for the rotation center though. The methods _3D.<Type>Animations.getTable
and _3D.<Type>Animations.<AnimationPathName.getTable now only return 8
instead of 11 values.

o An anchor point of an animation path of type Polycurve, compare Edit Path
Anchor Points, now only contains 9 instead of 12 values. You can still set
paths with 12 anchor points in the methods _3D.<Type>Animations.setTable and
_3D.<Type>Animations.<AnimationPathName.setTable, they will ignore the three
values for the rotation center though. The methods _3D.<Type>Animations.getTable
and _3D.<Type>Animations.<AnimationPathName.getTable now only return 9
instead of 12 values.

• We changed how the 3D Viewer handles the background color of 3D Frames. As long as
you do not set a model-wide background color, the 3D Viewer does not save a background
color in the model but uses the predefined color our programmers set. When loading
models which were created in previous versions of the program, the 3D Viewer interprets
these background colors as the predefined background color.

• We replaced the icons of the state graphics in the dialog  Show 3D Graphic Structure.
They now are spheres with the color matching the color of the respective state in 2D.

• We replaced the attribute  _3D.StatesVertical with the attribute _3D.StatesOrientation.

• We removed the tab Visibility from the dialog Edit 3D Properties.

o We removed the setting External graphic groups. Now external graphics groups
always represent their owning 3D object except those which are not marked visible.

o We renamed the setting Contained objects and internal graphic groups to
Show content and moved it to the Tab Graphics.

o The removed the check box Hide this object temporarily in all 3D windows.
You can still click Hide Object/Unhide Objects on the View ribbon tab.

o We removed support for the attribute _3D.Representation.

• We removed the function Show Coarse Grid and renamed the function Show Fine
Grid to Show Grid.

• We removed support of the attribute _3D.ExtSpline.

Back to What’s New in Tecnomatix Plant Simulation 13
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What's New in Tecnomatix Plant Simulation 12

What's New in Tecnomatix Plant Simulation 12

Tecnomatix Plant Simulation 12 provides a number of new and improved features.

• Important Changes in Plant Simulation 12

• New Features of the Material Flow Objects

• Changed Features of the Material Flow Objects

• New Features of the Resource Objects

• New and Changed Information Flow Features

• New and Changed User Interface Features

• New and Changed SimTalk Features

• Miscellany

• New and Changed 3D Viewer Features

As the program changed at a number of places, you might have to adapt simulation models
you created in previous versions of Tecnomatix Plant Simulation, when you open them in
Tecnomatix Plant Simulation 12.

Back to What’s New

Important Changes in Plant Simulation 13

Tecnomatix Plant Simulation 12 provides a number of new and improved features.

• The most important and noticeable new feature in  Tecnomatix Plant Simulation 11 TR 3
are the Fluid Objects.

•

We also rewrote the object HtmlReport 

• The most important and noticeable new feature in  Tecnomatix Plant Simulation 11 TR 2 is
the Ribbon Bar.

It replaces the menus and toolbars which the main program window and the object
windows in previous versions of the program offered. In this version you can still use
Menus and Toolbars though.
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Along with the ribbon bar, we also introduced  context menus with the  mini toolbar
and with symbols for most of the commands on the context menu itself.

• We further integrated the  3D Viewer into  Plant Simulation 2D. In most cases the  3D
Viewer now behaves the same as  Plant Simulation 2D.

Back to  What’s New in Tecnomatix Plant Simulation 12

New Features of the Material Flow Objects

Tecnomatix Plant Simulation 12 provides a number of new and improved features.
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New Features in Plant Simulation 12

• We added the command Open Without Control to the context menu of an object in the
Frame.

• We activated the command State Icons/LEDs for the Frame. In previous versions you
could only activate it with the attribute StatusWithIcons.

• We added the method importExporter. You can use it in the Request control of the 
importer.

New Features in Plant Simulation 11 TR 3

• We added the check box Exit control once / ExitCtrlOnce to the Exit control.

• We added the attribute TargetPosition to the  Transporter.

New Features in Plant Simulation 11 TR 2

• We added the optional parameter EndSim to the method stop of the  EventController.

• We added check box Part can only enter on cycle to the  Cycle.

New Features in Plant Simulation 11 TR 1

• We added the settings Relative converting point for the length and Relative converting
point for the width to the Converter. We also added the corresponding attributes
RelConvertingPointL and RelConvertingPointW.

Back to  What’s New in Tecnomatix Plant Simulation 12

Changed Features of the Material Flow Objects

Tecnomatix Plant Simulation 12 provides a number of changed and improved features.

Changed Features in Plant Simulation 12

• We changed the behavior of the point-oriented material flow objects which can accept
several parts. When several MUs were moved to a  ParallelProc, a  Store, a  Container, a 
Transporter with a matrix loading space, or a  Worker, the arrangement of the MUs on
the object sometimes was chaotic, i. e., the MUs were oftentimes not placed from top left
to bottom right onto the free storage places on the object. From now on the MUs are placed
onto the free storage places from top left to bottom right on the object.

This change also prevents the following problem: When all MUs on the object were to exit
at the same simulation time and when the object was failed before the MUs exited, the exit
order of the MUs sometimes changed once the failure was repaired.

• We changed the behavior of the Converter. When an MU is moved from a  Converter to
another object with the methods insert, move, or transfer specifying an index is not allowed
any more.  Plant Simulation ignores the specified index and moves the MU onto the target
object designated in the target control.

• We changed how to enter the Booking point length, the Booking point width, and the
Booking point height of the mobile objects. In previous versions you entered these as an
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absolute value for the length, width, and height. Now you enter the values as a
relative value between 0 and 1.

When you change the dimension of the MU,  Plant Simulation automatically
changes the absolute position of the booking point because the existing relative
position is preserved. When you then access the attributes  BookPnt,  BookPntH, 
BookPntL, and  BookPntW,  Plant Simulation now returns different values than in
previous versions.

 When you set the absolute booking point with the attributes BookPnt,
BookPntH, BookPntL, and BookPntW, the relative position of the booking
point will be calculated with the currently existing length/width/height
of the MU. When you subsequently change the length/width/height of
the MU, this results in a different position of the booking point, as the one
which you previously set wit the attributes.

We recommend to use the attributes BookPntHRelative, BookPntLRelative,
and BookPntWRelative from now on.

• We changed the behavior of the  Store. When you drag a  Method onto a  Store and drop it
there,  Plant Simulation now enters this  Method as the Entrance control not as the Exit
control  as before.

• We changed the order in which the Exit control and the Release control of the  Importer
are called when you defined both: In previous versions the exit control was called first
and then the importer release control was called twice. Now the importer release
control is called first and then the exit control is called once.

• We changed the behavior when you selected Times > Set-up time > Matrix(Type) or
Formula. When a set-up time of 0 results,  Plant Simulation does not start setting up, in
particular it does not request  Workers. The type of part for which the station is set up will
be set to the new type of part immediately.

• We changed how you define a polycurve (Tab Curve) in  Plant Simulation and in the  3D
Viewer:

• When you insert a straight segment after a curved segment,  Plant Simulation now always
enforces a tangential angle of 0°.

• When you create a new polycurve by clicking on an existing polycurve,  Plant Simulation
now uses the end angle of this polycurve as the start angle of the new polycurve. You can
prevent this by holding down the Alt key.

Changed Features in Plant Simulation 11 TR 3

• We changed the behavior of the setting setup After n parts and setup after last part.
In previous versions a new  Worker / Exporter was requested each and every time. Now 
Plant Simulation uses the  Worker / Exporter, who just finished working.

• We added an optional  boolean parameter to the Open control.

• We renamed these methods of the curved objects:  mirrorHorizontally to mirrorX and
mirrorVertically to mirrorY.

• We made the argument of data type table of the methods brokerStat, getOfferedServices,
getOpenImporters, getSatisfiedImporters, and serviceStat of the  Broker optional.
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• We made the argument of data type table of the methods typeStatistics and
typeStatisticsCumulated of the  Drain optional.

• We changed the behavior of the  Source when you select Time of creation > Interval
adjustable: When you change the interval before the next time of creation, an existing
CreateMU event will be deleted and will be scheduled anew with the interval starting
from the time of change.

• We extended the functionality of the method move of the moving objects. You can
now also enter an  array of objects to which the MU tries to move. When none of the
objects you entered as members of the array can accept the MU, it will be entered into the
blocking list of each of the objects that are members of the  array.

• We changed the behavior when you Merge Method classes. When the  Method to be
replaced was being executed while merging, for example because of the  Method was
suspended or when it was stopped at a breakpoint in the  Debugger, the old program code
was executed again when method execution was continued. The  Method then behaved like
a deleted attribute method, i.e., relative paths could no longer be evaluated correctly. The 
Method debugger then opened with an error message.

When the replaced  Method was continued after merging, the new program code will now
be executed and relative paths will be evaluated correctly.

Changed Features in Plant Simulation 11 TR 2

• We made vector graphics mode, compare the Tab Graphics, the default setting for the 
mobile objects. The default vector graphic of the  Entity looks like this , the  Container

looks like this ,and the  Transporter looks like this .

• We changed the name of the command  Frame > Modify Structure to Lock Structure.

• We changed the return value of the attribute Speed of the conveying objects, such as the
Line and the Transporter. When you enter  -1 for an infinite speed, the  SimTalk functions
and the dialog  Show Attributes and Methods now return or show -1. Previous version
returned/showed 1.#INF.

The current speed still returns/shows 1.#INF as the function returns negative values
when the object moves in reverse.

Changed Features in Plant Simulation 11 TR 1

• We changed how the Source creates parts. When you select the Operating mode >
Blocking, the  Source now stops creating parts when the simulation time has reached the
Stop time. In previous versions it stopped creating parts when the planned points in time
for creating parts were reached.

You can now also clear Blocking, i.e., activate non-blocking mode, and enter an Interval
of  0.

• We changed how  Plant Simulation calls the Pull control of the Converter. It now also calls
it for parts that move onto it moving in reverse.

• We changed how the Container shows its state. Now a pause always has precedence over
a failure. This also applies for statistics.
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• We changed how  Plant Simulation computes the next event for MUs. From now on it
computes the event before calculating the event of the following MUs. In previous versions
this was not always the case for collided MUs. This then could lead to a changed order of
simultaneous events of two MUs after they collided.

• We changed how Plant Simulation moves parts on from an  Interface or a  ParallelProc
with a Pull control if this Interface or ParallelProc only has a  single successor.
The setting Exit Strategy > Strategy > Blocking has no effect from now on. Plant
Simulation enters all MUs into the  blocking list of the simulation successor again as it
did in version 10.1.

• We enhanced drag-and-drop for a Frame class on a Connector in a  Frame. When
that Frame contains a suitable Entrance Interface and a suitable Exit Interface, Plant
Simulation inserts an instance of the Frame between the end objects of the Connector and
adjusts the  Connectors.

Back to  What’s New in Tecnomatix Plant Simulation 12

New Features of the Resource Objects

In  Tecnomatix Plant Simulation 12 we added these features to the resource objects:

• We added the methods doStandardExport, doStandardImport, and getExportersForService
to the  Broker.

• We added the attribute AutomaticMediation to the  Exporter and to the  Worker.

• We added the read-only attribute AvailableForMediation to the  Exporter and to the 
Worker.

• We added the methods getRouteLength to the  Workplace.

• We changed the behavior of a failed  Worker. They now stop instead of walking towards
their destinations as they did before.

• We changed the behavior of the  Worker. In previous versions a  Worker, who picked up
parts to carry them to the target station, forgot the dwelling time after a failure of the
station and delivered the parts immediately after picking them up. Now it also considers the
dwelling time after a failure.

• We changed the behavior of the method engage of the  Broker. Up until now it did not
interrupt  Importers with a lower priority although the method testImportFor also returned 
Exporters whose current job had a lower priority.

Back to  What’s New in Tecnomatix Plant Simulation 12

New and Changed Information Flow Features

Tecnomatix Plant Simulation 12 provides a number of new and improved features.

New and Changed Features in Plant Simulation 12

• We added the columns Insertion Time and Parameters to the table which the method
getEventList of the EventController returns.

• We added the method getColumnYDim to the TableFile.
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• We made the argument of data type table of the method getStatisticsTable of the Variable
optional.

• We changed how Plant Simulation executes  observer methods: When an observer and
another control were triggered at the same time, until now the control was executed first
and when then the observer was executed. We changed this that now observer is called
first and only then the control is called.

The previous execution sequence had the disadvantage that calls of an  observer method
could pass each other. If the control changed the observed attribute anew, the observer
was triggered again anew, i.e., the control was interrupted and the observer was
executed with the second value change. Then the execution of the control was continued
and only then the observer was executed with the first value change.

With the new, changed execution sequence this problem cannot occur any more, as the
observer with the first value change is executed before the control. In addition, the
new execution sequence has the advantage that observers now behave more similar to 
suspended methods, which always had precedence over controls and observers.

New and Changed Features in Plant Simulation 11 TR 3

• We added the return value of data type list to the method createNestedList of the 
TableFile.

• We added the return value of data type boolean to the method setCursor of the  TableFile.

• We renamed the command Highlight Void Cells on the List ribbon tab to Highlight
Empty Cells.

• We changed the behavior of built-in methods which expect a  list or a  table, for example 
putAttributeNamesIntoTable. In previous versions these could only be called with an
instantiated  list or  table, i.e., you had to tell  Plant Simulation to create it first:

Example:
local tab: table;
tab.create; -- was required in the past
  
 SingleProc.putAttributeNamesIntoTable

From now on you can also pass a non-instantiated  list or  table.  Plant Simulation then
creates it automatically:

Example: local tab: table;
SingleProc.putAttributeNamesIntoTable

• We changed the behavior of the Trigger: For a TriggerStart  event  Plant Simulation does
no longer assign the value to the attribute, which corresponds to the start time (in most
cases the first value in the Values table), but the previous value on the table. If this value
does not exist, because the first row in the values table applies to the start time, Plant
Simulation assigns the Default value.

• We removed the button Attributes from the tab Actions of the  Trigger.

New and Changed Features in Plant Simulation 11 TR 1

• We changed the behavior of the feature Column index belongs to contents of the  list
objects under Format > Format .
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For new models the check box is activated by default again as it was in previous versions.

• We changed the behavior of the AttributeExplorer. It no longer adds  Connectors when you
drag connected objects onto it and drop them there. It also removes empty rows from the
tables on its tabs when you click OK or Apply .

• We added the method increment to the  TableFile.

• We added the menu command Outlining to the Edit menu of the Method.

• We added the text box Decimal places and the attribute DecimalPlaces to the Variable.

• We added the methods loadFromFile, saveToFile, storeStatement and useStatement to the
SQLite interface.

• We added the statistics values Time to set single item, Time to get single item, Time to set
multiple items, and Time to get multiple items to the object OPC.

• We added the return value -1 to the method selectSyncFromDialog of the Teamcenter
interface. It tells that the user closes the dialog by clicking Cancel.

• We changed the behavior of  Lists and  Tables, which you opened in the foreground as a
dialog with the method openDialogBox.

o Changes you make to the contents of a cell are now displayed immediately in that cell.

o The list object now also accepts the decimal point, in addition to the comma, for
floating-point numbers and times.

• We removed support of the methods  closeFile,  openFile,  readFileRow, and of the
attribute  FileCursor of lists and tables. You can use the method readFile instead.

Back to  What’s New in Tecnomatix Plant Simulation 12

New and Changed User Interface Features

Tecnomatix Plant Simulation 12 provides a number of new and improved features.

New and Changed Features in Plant Simulation 12

• We extended the functionality of the HtmlReport. It can now display objects to type 
Checkbox,  DropdownList,  FileLink, and tables which the object  SQLite contains.

We also added the dialog Object Parameters into which you can enter the settings
which some objects require.

• We removed the  HtmlWizard. The  HtmlReport now provides most of its functionalities.

New and Changed Features in Plant Simulation 11 TR 3

• We added the object HtmlReport. It replaces the  Report, which previous versions of the
program provided.

• We changed the behavior of the objects Button, Checkbox, and Drop-Down List. When
you enter a Height of more than 30 pixels or drag the border of the icon of the object, 
Plant Simulation uses a larger font to display their label.
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• We changed the behavior of the object Comment. You no longer have to click Apply after
activating Save the contents in rich-text format to actually activate the feature.

New and Changed Features in Plant Simulation 11 TR 1

• We added the text box Interval and the attribute YGridLineInterval to the object Chart.

• We added the menu command Use Metric Prefix and the attribute UseMetricPrefix to the
object Chart.

• We added the setting Right, stacked to the drop-down list Legend of the object Chart.

• We added the attribute getHTMLCode to the object Chart.

• We added the attribute appendToContent to the object Comment.

• We added the attribute Items to the object Drop-Down List. It replaces the methods 
getItems and  setItems.

Back to  What’s New in Tecnomatix Plant Simulation 12

New and Changed SimTalk Features

Tecnomatix Plant Simulation 12 provides a number of new and improved features.

New and Changed Features in Plant Simulation 12

• We replaced the function  version with the function applicationVersion.

• We added the method max for one-dimensional arrays with a numerical data type and with
the data type  string.

• We added the method min for one-dimensional arrays with a numerical data type and with
the data type  string.

• We added the method sum for one-dimensional arrays with a numerical data type.

New and Changed Features in Plant Simulation 11 TR 3

• We added the function getLibraryFiles.

• We added the function _3D.isGraphicGroupGenerated.

• We added the methods copyFromTableColumn and copyToTableColumn to the  one-
dimensional arrays.

New and Changed Features in Plant Simulation 11 TR 2

• We removed support for the function  resetClipboard.

• We removed support for the method  copyToClipboard.

• We added the function copyObjectsToClipboard.

• We added the function getLibraryFiles.
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New and Changed Features in Plant Simulation 11 TR 1

• We added the function setInfiniteLoopDetectionTimeout.

• We added the function splitString.

• We extended the function startExtProc with two optional parameters.

Back to  What’s New in Tecnomatix Plant Simulation 12

Miscellany

Tecnomatix Plant Simulation 12 provides a number of new and improved features.

New and Changed Features in Plant Simulation 12

• We added the button Open Event Controller to the Home ribbon tab and removed the
launch dialog button below the  EventController buttons.

• We added the attribute HiddenWhenInLockedFolder to the  folder in the  Class Library.

• We added the description of the Tutorial to the  Online Help.

• We added the topic Available Features of the Individual Licenses to the  Online Help

• We removed the buttons Previous Icon and Next Icon from the Edit
ribbon tab of the  Icon Editor. You can click the respective buttons

 in the dialog window of the  Icon Editor
instead.

• We removed the options to show or hide Print messages, Info messages, and other
messages under File > Preferences > User Interface > Console filter. These
messages are now always active.

• We removed the setting for entering the size of the toolbox icons from File >
Preferences > User Interface.

• We added the function Damping time to the  Cross Sliding Car.

• We added the function Take preferred position to the  Cross Sliding Car.

New and Changed Features in Plant Simulation 11 TR 3

• We added functions to the command Configure User-defined Ribbon Tab.

• We changed which icon of an object  Plant Simulation displays in the Toolbox by default.
In previous versions it always displayed the first icon, i.e., the icon with the number 1. It
now checks if an icon named ToolboxIcon exists. If this is the case, it displays this icon,
if this is not the case, it displays the first icon.

• We replaced the button Open EventDebugger on the Home ribbon tab with the button

Real-Time .
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• We changed the order in which the Importer request control and the Exporter request
control, which you defined on the Tab Controls of the Broker, are called.

o When you defined Exporter and Importer request controls, the Exporter
request controls will now be executed first. This way you can make the  Worker
follow the part when the part moves to the next station. This causes changed behavior
as compared to modeling without controls. Without controls, the  Worker is brokered
for the new station in the  Workerpool.

o When several Importer request controls are executed at the same time, for
example because an  Exporter is released and when several open  Importers exist, the
sequence of the controls now matches the sequence of the  Importers in the list Open
Importers. This way brokering of  Exporters now behaves identical when you model
with our without controls.

New and Changed Features in Plant Simulation 11 TR 2

• We added the method lockFolder to the folder.

• We added the feature Lock library  to lock a library.

• We added the VSM (Value Stream Mapping), Shop, and Assembly libraries to the
libraries which you can borrow in the dialog Borrow Licenses.

New and Changed Features in Plant Simulation 11 TR 1

• We now enable administrators to set default values for simulation models, compare Setting
Default Values in the Windows Registry.

• We changed the order of the menu commands of the Tools Menu.

• We added the functions Encrypt Model File and Restrict Permission to the Tools Menu.

• We changed what the function Encrypt Methods does:

The command now encrypts all  Methods except for the prototype  Method in the folder 
InformationFlow.

In addition it now also encrypts all user-defined attributes of data type  method, which are
located within the built-in objects in a new model, such as the Callback method of the
built-in prototype of the object  Dialog.

In previous versions the command generally did not encrypt  Method classes and no user-
defined attributes of data type  method of classes. This then prevented all instances of 
Methods and all user-defined attributes of data type  method, which inherited their source
code from a not encrypted  Method class or user-defined attributes of data type  method,
from being encrypted when you called the command.

• We added the tab 3D to Tools > Preferences and the tab 3D to Tools > Model
Settings. It replaces the 3D preferences which you could select under Tools > 3D
Preferences in previous versions of the program.

• We added the setting User interface concept to Tools > Preferences > User Interface.
You can select if you want to show menus and toolbars in the  Plant Simulation user
interface or if you want to use the ribbon bar.
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• We integrated the 3D Library into the Class Library in the main program window. You
find information about the 3D structure of the selected object in the window Show 3D
Graphic Structure.

• We added a toolbar to the window Show Structure.

• We added the method setRequiredLicense to the  folder.

• We changed the sort order of the interaction controls, which you defined for an object, on
its context menu in the  Frame. Thecontrols are sorted now alphabetically.

• We changed how you can select the currency you want to use in your model. In addition
to selecting it, you can now also enter it directly into the drop-down combo boxCurrency
under Tools > Preferences > Units.

• We modified the function Print for printing the contents of a  Frame or for printing the
source code of a  Method. It now shows the last selected printer when you print one of the
above.

•
We removed the button  Switch Console Messages On/Off from the Console
window. When you display the  Console,  Plant Simulation now records messages, when
you hide it, it does not record messages.

• We removed the boolean parameter from the function closeConsole.

• We changed how  Plant Simulation shows on the labels of the tabs of minimized windows
on the  tab bar. The length of the displayed label now depends on the number of displayed
tabs and the width of the program window as well as the median width of a character of the
font used. If the tab is too narrow,  Plant Simulation abbreviates the displayed object path,
just like it does in the title bar of the object window, by showing an ellipsis … The tooltip
always shows the entire path though even if a window is minimized.

• We changed the behavior of the method getLibraryInfo. The fourth optional parameter now
designates the file path of the library file (.lib).

• We added the function checkForLicense.

• We added the function createLicenseFile.

• We added the method getLibraryVersionFromFile.

• We added the optional parameter  Password to the method loadModel.

• We added the optional parameter  Password to the method loadModel of the COM
Interface.

• We added the optional parameter  Password to the method writeObject.

Back to  What’s New in Tecnomatix Plant Simulation 12

New and Changed 3D Viewer Features

Tecnomatix Plant Simulation 12 provides a number of new and improved features.
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New and Changed Features in Plant Simulation 12

• We added a number of topics to the chapter Modeling in the 3D Viewer of the  Step-by-
Step Help.

• We added the command Show Point Clouds to the View ribbon tab of the  3D Viewer.

• We added the Tab Point Cloud to the dialog 3D Properties of the  Frame. We also added
the corresponding Built-in Attributes for Point Clouds of the Frame.

• We added the Tab Graphic Sequences to the dialog 3D Properties of the  Worker.

• We added settings for arranging States orientation.

• We added the command Edit 3D Properties to the Context Menu of a State Graphic.

• We added the command Insert Fence to the Edit Ribbon Tab.

• We raised the number Camera Marks, which you can define, from 20 to 40.

• We enhanced the Paste command. It now pastes the object with an offset to the original
position.

• We improved handling of the  3D Viewer to also support two-button mice:

• Shift + right mouse button now also zooms the scene

• Ctrl + right mouse button now also rotates the scene

New and Changed Features in Plant Simulation 11 TR 3

• We added the command State Graphics to the Context Menu of a 3D Object. This way you
can create state graphics that match the LEDs in 2D. These replace the state objects of
previous versions.

• We added the button Add Rotation to the Tab Transformation of the dialog Edit 3D
Properties.

• The 3D Viewer now uses anti-aliasing for displaying objects in the 3D scene.

• We switched to version 8.1 of the Direct Model engine for displaying 3D. We strongly
recommend to update your graphics card driver to make sure that your 3D model will be
displayed correctly.

Update the graphics card driver from the website of the manufacturer of your
graphics card to make sure that you receive the most up-to-date drivers.

• We removed the tab Connect data from the dialog Edit 3D Properties. We moved the
functions Connect 2D and 3D positions and Connect 2D and 3D rotations to the Tab
Transformation.

• We removed the buttons Accept Rotation and Accept Scale (and the corresponding
attributes  _3D.acceptRotation and  _3D.acceptScale ) from the Tab Transformation.

• We removed the button Reset Camera from the View ribbon tab.



Chapter 1   What's New

1-64  Stand-alone TopicSet           

• We changed the behavior of the  3D Viewer when an object camera is active, which you
attached to an object with the command Attach Camera:

• You cannot change the view as long as the view of the object camera is active. To return to
interactive navigation mode, you have to remove the camera by clicking Detach Camera or
switch camera mode by clicking Toggle Camera.

• The  3D Viewer removes the camera, when you delete the object to which it was attached.
Removing an object camera automatically resets the view.

New and Changed Features in Plant Simulation 11 TR 2

• We added the function Internal to the context menu of the dialog  Show 3D Graphic
Structure. It determines if the selected graphics group will be used for visually
representing the object to which the graphic belongs.

• We added settings for entering the object coordinates for objects you create with the
commands Make Animatable Object and Make Simulation Object.

• We added the settings Animation object and MU side to attach to the tab MU Animation
of the dialog  Edit 3D Properties.

• We added a number of Built-in Methods for Accessing Graphic Groups.

• We added a number of Built-in Attributes for Accessing Graphic Groups.

• We added the read-only attribute _3D.NumObjects.

• We added the method _3D.<Type>Animations.playAnimation.

• We changed the function Insert Textured Plate.

• We adjusted the drag-and-drop function of the  3D Viewer. When you drag something onto
a  3D Viewer window this now has the same effect as when you drag something onto a 
Frame window in 2D.

• We removed the function Connect 3D Viewer and the corresponding  SimTalk functions.
You cannot run the  3D Viewer without a connection to  Plant Simulation any more.

• We removed the menu command View > Hide > Unhide Scene Graphics as you
cannot hide individual graphic groups any longer with the command Hide.

If you want to change the visibility of individual graphic groups of the selected
object, for example temporarily while modeling, you can select the check box
Visible on the context menu of the dialog  Show 3D Graphic Structure or on
the Tab Graphics > Visible of the dialog  3D Properties of the object.

This setting is, in contrast to the command Hide Object, permanent and applies to all 3D
windows which contain the object.

• We removed the check box Show Graphics under File > Preferences > 3D > View
Settings as you can now define graphics to be internal or external graphics.

Note that graphics of models, which you created in previous versions of the program,
initially are treated as external graphics. As Show External Graphics now always is
deactivated by default when you open a model, you might have to define some graphics as
being internal in your old models so that these look the same as before.
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• We removed the check box Select Children under File > Preferences > 3D > View
Settings.

New and Changed Features in Plant Simulation 11 TR 1

• We removed the tab  3D Library from the program. We integrated the  3D Library into
the Class Library and replaced parts of its functionality with the dialog that the command
Show 3D Graphic Structure of the selected object in the  Class Library opens. The context
menu command Show Graphic Structure in the 3D scene window shows the same
information. So does the button Show Graphic Structure in the dialog  3D Properties
of the object.

• We moved the settings for the Grid from the Tools menu to the View menu. We also
simplified the settings.

When you open the  3D Viewer, the grid in the scene window looks like this:

When you insert and move an object towards the borders of the grid, it automatically
extends in that direction. The grid always expands or shrinks to show all objects in the
scene.
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• We changed the functionality of the command Edit > Attributes. You can now only view
them, you cannot edit them any more. We removed the command Tools > Attributes >
Viewer.

• We changed when the program offers MU animations in the  3D Viewer via  SimTalk.
They are now only offered for those 2D objects which actually can accommodate  MUs or 
Workers.

• We changed how you can paste graphics. You cannot paste graphics into the selected
graphic in the 3D scene window any more. Instead, you can only paste the graphic into the
graphic group of the selected object in the 3D scene window. You can now paste graphics
in the dialog Show 3D Graphic Structure.

• We added a new feature: The  3D Viewer can now also show the icons of most of the
objects, which are not relevant for 3D, such as the  information flow objects, in the 3D
scene. To do so, double-click the icon of the object, for example of the  TableFile, in the 
Toolbox and select Tools > 3D. Select the check box Create in 3D. When you then insert
an instance of this object into the 3D Scene, it shows the icon of the object. You can then
click the icon with the right mouse button and select Open 2D Counterpart to open the
dialog of the object in 2D.

• We added the Tab Auto Graphics for MUs to the dialog 3D Properties.

• We added the check box Visibilities to the Tab Graphics.

• We added the menu command Optimize Selected Graphic to the Edit Menu.

• We added the menu command Make Simulation Object to the Edit Menu.
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•

We added the functions Show Fine Grid  and Show Coarse Grid  to the
toolbar 3D Modeling.

• We added the submenu commands Cancel Recording, Pause Recording, and Finish
Recording to the Tools Menu.

• We added the menu command Edit 3D Properties to the context menu of the  Frame in the 
Class Library.

• We added the menu command Edit 3D Properties to the context menu of the dialog
Show Structure in the  Class Library.

• We added the method _3D.concatenateRotations to execute several rotations in one step as
a single rotation.

• We replaced the methods  _3D.flattenGraph and  _3D.pruneTinyGraphics with the method
_3D.optimizeGraphic.

• We enhanced the way you can select objects in the  3D Viewer. Just like in  Plant
Simulation 2D you can now drag a selection rectangle around the objects you want to
select. When you do not hold down a modifier key, dragging a marquee cancels an existing
selection. When you hold down the Shift or the Ctrl key, the objects within the marquee
are added to the existing selection.

• We changed the version of Direct Model on which the  3D Viewer is based on to Direct
Model 8. For it to work correctly driver version 8.911.3.3 or higher has to be installed for
AMD FireGL and FirePro graphics cards.

• We changed the JT format version when saving models containing a 3D part and when
saving .s3d files. We now use version 10.0. When exporting JT files we use version 9.5.

• We changed when you can model in the  3D Viewer. It now only works when a connection
between  Plant Simulation and the  3D Viewer has been established and is active.

• We changed how you can cancel moving an object in 3D while holding the left mouse
button down and dragging the mouse. To do so, press the Esc key, just like you do in 2D.
Each action with the mouse or keyboard keys, which transforms an object or a graphic, is
applied as soon as you release the mouse button or the keyboard key.

• We removed the menu command Background Color from the Tools Menu. You can
now change the background color of each  Frame on the Tab Background Color in the
dialog 3D Properties. As opposed to previous versions, you can now also assign white as
the background color.

We also added the corresponding attributes _3D.BackgroundBrightness and
_3D.BackgroundColor.

• We removed the menu command Update 2D Model from the 2D Menu.

• We renamed the menu commands Tools > Import Geometry and Tools > Export
Geometry to Tools > Import Graphics and to Tools > Export Graphics.

• We renamed the method  _3D.importGeometry to _3D.importGraphics.

Back to  What’s New in Tecnomatix Plant Simulation 12
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What's New in the Object Libraries

What's New in the Object Libraries

The object libraries in Tecnomatix Plant Simulation 13.x provide a number of new and
enhanced functions.

• We added the GantryLoader to the Cranes Library.

• We adjusted the position and the dimension of the racks and the conveyors in the library
High Bay Warehouse (HBW) so that no gaps appear when you insert them into your
model.

• We enhanced the functions of the object Warehouse Management System (WMS) in the
library High Bay Warehouse (HBW).

Back to What’s New

Value Stream Mapping Library

Value Stream Mapping Library

We fixed the following bugs and added the following features to the Value Stream Mapping
library.

• Value Stream Mapping Library Version 12.0.10

• Value Stream Mapping Library Version 11.0.14.2

• Value Stream Mapping Library Version 11.0.14.1

• Value Stream Mapping Library Version 11.0.13.7

• Value Stream Mapping Library Version 11.0.13

• Value Stream Mapping Library Version 11.0.12.3

• Value Stream Mapping Library Version 11.0.12.2

• Value Stream Mapping Library Version 11.0.12.1

• Value Stream Mapping Library Version 11.0.12.3

• Value Stream Mapping Library Version 11.0.11.2

• Value Stream Mapping Library Version 11.0.11.1

• Value Stream Mapping Library Version 11.0.11

Back to What’s New in the Object Libraries

Back to What’s New
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Value Stream Mapping Library Version 12.0.10

We added the following features in Version 12.0.10 of the library:

• We add the button Edit t]o the Tab Product of most objects.

• We add the check box Use product groups to the Tab Statistics of most objects.

• We added product groups to the Tab Product of the object PPS.

• We redesigned the object Supplier.

• We redesigned the object TransportExternal.

Caused by the changes we made to the objects Supplier and TransportExternal,
existing simulation models can behave differently. The products on the Supplier
can accumulate because the object TransportExternal does not provide sufficient
transport capacity. As a consequence memory consumption can increase
dramatically.

Back to What’s New in the Object Libraries

Value Stream Mapping Library Version 11.0.14.2

We changed the behavior of the object Work in Process (WIP) [on Version 11.0.14.2 of the
library. Now it not only shows a snapshot of the current work in process. You can also activate
the collection of the work in process during the simulation run and you can evaluate the
collected data afterwards. You can define the interval for collecting the data.

Back to What’s New in the Object Libraries

Value Stream Mapping Library Version 11.0.14.1

We added the object ForeignOrders to Version 11.0.14.1 of the library. You can use it to define
additional production orders for processing objects which are shared with other production lines.

Back to What’s New in the Object Libraries

Value Stream Mapping Library Version 11.0.14.0

We fixed the following bugs and added the following features to the Value Stream Mapping
library in Version 11.0.14 of the library.

• We changed the handling of Interfaces of the Value Stream Mapping objects.

• We added the object Rework. This was necessary to allow Plant Simulation to identify the
correct Interface then connecting the object using for example the material flow connector
or for example the  [information flow connector.

You can use the object Rework object to model a reworking process within your value
stream processes.

• We added the object LeadProcess. You can use this processing object to simulate a lead
time and a cycle time. First the product has to spend the lead time for processing. The
products then leaves the object using the  cycle time. If the lead time is the same as the
cycle time, the LeadProcess behaves like the object Process.
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• We added the object ScheduleBox. You can use it to define a list of production orders
which will be transferred to the processing object connected with the ScheduleBox.

Back to What’s New in the Object Libraries

Value Stream Mapping Library Version 11.0.13.7

We fixed a bug of the object Customer then using a fixed date for production orders. You can
now define a start date on the EventController which is long before the first customer order
starts.

Back to What’s New in the Object Libraries

Value Stream Mapping Library Version 11.0.13

We fixed the following bugs and added the following features to the Value Stream Mapping
library in Version 11.0.13 of the library.

• We added the object FlowGrade which was part of the object Analyzer on previous
versions.

• We removed the object Analyzer from the library. You can use object FlowGrade instead.

• We modified the product table on the dialog of the Supermarket.

• We modified the behavior of the object ProcessIndexed. The processing time is now
defined again during the initialization phase. This fixed a problem which sometime
prevented the processing time from being set to a fixed time.

Back to What’s New in the Object Libraries

Value Stream Mapping Library Version 11.0.12.3

We fixed the following bugs and added the following features to the Value Stream Mapping
library in Version 11.0.12.3 of the library.

• We added the object FIFO_Analyzer.

• We modified the behavior of the object UtilizationAndStock. Its display can now be closed
with one click.

• We fixed a bug in the object ProcessAssembly, which occurred when you double-clicked
into the table of the sub-products.

• We modified the behavior of the object Check. It now checks if there are more than one
object of type FIFO/Transport is located in front of a ProcessAssembly station. Only one
object of type FIFO/Transport is allowed.

Value Stream Mapping Library Version 11.0.12.2

We added the following feature to the Value Stream Mapping library in Version 11.0.12.2 of the
library.
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• We added the object ScheduleBox.

Value Stream Mapping Library Version 11.0.12.1

We fixed the following bug in Version 11.0.12.1 of the Value Stream Mapping library.

• We fixed a bug which caused an error when products with the transfer quantity if
1 were produced in a sequence of stations and when the same product was produced
repeatedly.

Value Stream Mapping Library Version 11.0.11.2

Value Stream Mapping Library Version 11.0.11.2

We fixed the following bugs and added the following features to the Value Stream Mapping
library in Version 11.0.11.2 of the library.

• Customer

We changed the title of the Chart for the delivery time.

• Process_indexed

We changed the statistics evaluation.

• Inventory

We fixed a bug that occurred when closing the edit table.

Back to What’s New in the Object Libraries

Value Stream Mapping Library Version 11.0.11.1

We fixed the following bugs and added the following features to the Value Stream Mapping
library in Version 11.0.11.1 of the library.

• Check

o We changed the behavior of the object. It now checks if all connections are VSM
Connections.

o We changed the text of some error messages to make them easier to understand.

• MRP

We fixed a bug that occurred when you modeled rework processes without using a Rework
Connector.

Back to What’s New in the Object Libraries

Value Stream Mapping Library Version 11.0.11

We fixed the following bugs and added the following features to the Value Stream Mapping
library in Version 11.0.11 of the library.
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• Inventory

We changed the dialog of the object to match the same look and feel of the dialogs of the
other processing objects.

When closing the dialog while the  product table is open, the program now also closes
the window of the table. This deletes all of your changes to the table. We recommend
closing the  product table before closing the object dialog.

• Kanban

o We revised the Heijunka functions. You cannot enter any values into the time slot
after the last time entry any more.

o We extended the Heijunka function. You can now define any value for the interval of
the Heijunka board.

• Customer

We extended the functions of the object. You can now directly connect the Customer
with an Information Connector with a Supermarket. In this case, the Customer orders
the products from the Supermarket and the Supermarket handles the production of the
products.

• Supermarket

We changed the behavior of the object. When products arrive at the Supermarket, and the
order is finished, it now checks if the reorder level has been exceeded. If this is the case, it
creates a new order.

Back to What’s New in the Object Libraries

Value Stream Mapping Library Version 11.0

We fixed these bugs, we extended the functionality of Value Stream Mapping objects, and we
added new objects to the library:

• We fixed some bugs for the strategy Kanban-Box of the object Kanban.

We extended the functionality of the object. You can now also define Parts per Kanban
Card as 1 part. If you defined scrap or rework in the line where the Kanban parts are
processed, this will also be treated correctly. In a  Kanban production line you can now
define XBP>1 and XBP<1. Both cases will be treated correctly.

• We extended the functionality of the object Supplier.

o In addition to the Disposition of the object PPS you can now also define the delivery
of products interval-driven. By defining an interval of n minutes, the defined number
of products will be delivered every n minutes.

o You can now use a Supermarket for ordering parts from the Supplier.

o A Kanban object can also order parts from the supplier (Supplier-Kanban ).

o You can now also export the delivery days and the data for cyclical delivery.

o We added a chapter to the help of the Supplier object in which we demonstrate how to
use the different functionalities.
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• We added the object EPEI. It computes the EPEI value of all processing objects in your
value stream mapping model.

• We redesigned the object Check. Now the consistency check of the objects PPS and Check
use the same functionality.

• We added help for the Value Stream Mapping library to the Tecnomatix Plant Simulation
Online Help.

• We extended the functionality of the object DataExchange. It now also stores the
Heijunka boar of the object Kanban as well as the contents of the table of the Kanban
box.

• Note that because of these changes is no longer possible to read in Excel files created with
older versions of the value stream mapping library.

Back to What’s New in Tecnomatix Plant Simulation 11
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